Master-Password prompt apperars when user is typing

RESOLVED DUPLICATE of bug 1149500

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 1149500
23 days ago
20 days ago

People

(Reporter: elo95, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

23 days ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171026211016

Steps to reproduce:

Set Master password, open first instance Firefox, immediately start typing in searchbar or addressbar or some other textbox


Actual results:

Entry in current selected textbox is interrupted by master-password prompt, 
I usually look at my keyboard while typing, so I do not notice the prompt and continue to enter my query, then I press enter to start the search i intended. Of course firefox says wrong master-pwassword and reopens the prompt. The problem is, that I have to close the prompt and retype my search query. 


Expected results:

The prompt for the password only shows when I'm done typing my search query (and started the search) or when i start using my mouse, something, that indicates that I'm looking at the screen.
OR the promt appears immediately after firefox is opened.
OR The promt won't appear, when a textbox (on a website or firefox) is currently active

Updated

22 days ago
Component: Untriaged → Password Manager
Product: Firefox → Toolkit
This is a dupe of dug 1149500 if it's from a background login form load or if it's from Sync then it's another known issue that Sync triggers the dialog.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 20 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149500
You need to log in before you can comment on or make changes to this bug.