Viewing several Motion JPEG pictures causing memory leak

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
24 days ago
21 days ago

People

(Reporter: 1for-matik, Unassigned)

Tracking

({regression})

58 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

24 days ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171028100423

Steps to reproduce:

Browse pages with several Motion JPEG pictures (example : http://www.insecam.org/en/bytype/Axis/ )

(test the firsts pages....)


Actual results:

Page slows down browser causing memory leak (it not happen on every page)

Don't know if it's ImageLib related or Javascript related, but Mozregression as a regression range :

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6212837ec87882ebfc8e5a697f3ee4e9109ca41f&tochange=89ffef35daade74a97ad36134a78898a8cf3155b

(So Firefox 57.0 bĂȘta 12 is affected too...)


Expected results:

Page shouldn't slow down as much as the bug does and there shouldn't be a memory leak.
The regression range seems unrelated to your issue. Can you please rerun mozregression?
Keywords: regression
(Reporter)

Comment 2

24 days ago
OK, done some tests with another computer and it seems not affected by my bug (nVidia GT 610).

So, on the bugged computer (AMD R7 240), i can resolve the bug by disabling hardware acceleration.

And now, i have an another regression range : https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=89ffef35daade74a97ad36134a78898a8cf3155b&tochange=01d20d2ebb57d1be52e87e4666e661577335c16e

Comment 3

24 days ago
@Reporter,
Could you attach about:support results of the affected one?
Flags: needinfo?(1for-matik)
(Reporter)

Comment 4

24 days ago
Well, seems i can't reproduce the bug, but it's after disabling/re-enabling hardware acceleration that the bug resolved itself...

Strange... sorry for the inconvenience.
Flags: needinfo?(1for-matik)
(Reporter)

Comment 5

24 days ago
For info, first Mozregression was on the AMD drivers 17.10.1 (2 GB memory leak max), second one was on the 17.10.3 (1.4 GB memleak max)

Now i can't reproduce it with Mozregression since memory is stable about 500-600MB...
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Firefox: 58.0a1, Build ID 20171031220132

I have not managed to reproduce this issue, using the steps provided in the description, on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12.6 with the latest Firefox release (56.0.2) and latest Nightly (58.0a1) builds.

@1for-matik, if you can no longer reproduce the issue, do you think we can close this as resolved - worksforme? And if you reproduce the issue in the future, could you please save a memory report using the about:memory page?
Flags: needinfo?(1for-matik)
(Reporter)

Comment 7

21 days ago
Yes we can close this bug. I still can't reproduce the bug and have no idea what was causing it even with Mozregression download builds (since Mozregression profile should be clean, so no webrender or others optional stuff activated).
Flags: needinfo?(1for-matik)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 21 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.