Closed Bug 1412588 Opened 2 years ago Closed 2 years ago

Update rustc tooltool package to 1.21

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.55 fixed)

RESOLVED FIXED
seamonkey2.55
Tracking Status
seamonkey2.55 --- fixed

People

(Reporter: ewong, Assigned: ewong)

Details

Attachments

(1 file)

need to update rust to 1.21
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8923138 - Flags: review?(frgrahl)
going to bustagefix-post-land-review this.
Pushed by ewong@pw-wspx.org:
https://hg.mozilla.org/comm-central/rev/bf29aafeeae3
Update Rust to 1.21 r=bustagefix
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Pushed by ewong@pw-wspx.org:
https://hg.mozilla.org/comm-central/rev/36ad3fb2f6cb
Update Rust to 1.21 r=bustagefix
(In reply to Pulsebot from comment #4)
> Pushed by ewong@pw-wspx.org:
> https://hg.mozilla.org/comm-central/rev/36ad3fb2f6cb
> Update Rust to 1.21 r=bustagefix

this was a bustagefix..
Comment on attachment 8923138 [details] [diff] [review]
[tooltool] update rustc packages

Looks fine. Thanks
Attachment #8923138 - Flags: review?(frgrahl) → review+
It looks now that the packages need to be uploaded to tooltool for use in TB and SM. See Bug 1412290.
Target Milestone: --- → seamonkey2.55
Version: unspecified → Trunk
Comment on attachment 8923138 [details] [diff] [review]
[tooltool] update rustc packages

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: no builds on beta
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #8923138 - Flags: approval-comm-beta?
Comment on attachment 8923138 [details] [diff] [review]
[tooltool] update rustc packages

a=me
Attachment #8923138 - Flags: approval-comm-beta? → approval-comm-beta+
I think it was a mistake to uplift this to C-B for the following reason:

Mozilla have merged M-C to M-B very early this time. Therefore we're trying to build a C-B version of 57 onto an M-B version of 58 which clearly will fail.

Updating Rust to 1.21 will get you past the first hurdle, but I'm sure you can't even compile anything.

If you want to build a beta, you need to base it on the FIREFOX_57b_RELBRANCH on M-B.

If you agree, please back this out:
https://hg.mozilla.org/releases/comm-beta/rev/44259af6a276b20ac07acfed8dae334a446f0795
You need to log in before you can comment on or make changes to this bug.