Closed Bug 1412621 Opened 2 years ago Closed 5 months ago

Frequent 30 FPS VSYNC in Windows 10 Fall Creators Update (version 1709)

Categories

(Core :: Graphics, defect, P2)

58 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox57 --- wontfix

People

(Reporter: public, Unassigned, NeedInfo)

Details

(Whiteboard: [gfx-noted])

Attachments

(3 files)

Attached file Graphics report.txt
Since updating to the Fall Creators Update I've been getting frequent drops to 30 FPS in Firefox, most noticeable when scrolling or watching a video. This is a fresh install of Windows using a fresh install and fresh profile in Firefox 56.0.2 and 58.0a1 (2017-10-28), with the latest graphics drivers.

I haven't been able to reliably reproduce it, but it seems to occur most frequently when more than one Firefox window is open, or when playing a video. I haven't observed any increase in CPU or GPU usage while the issue is occurring.

I have not seen this issue in Edge, or any other application, so if it's a Windows bug, it only seems to affect Firefox.
Component: Untriaged → Graphics
Product: Firefox → Core
Flags: needinfo?(hshih)
Whiteboard: [gfx-noted]
Still an issue on Firefox 58, which continues to make the Fall Creators Update unusable to me.

New info though, having a window on screen which does hold VSYNC properly, such as Edge with a 60FPS animation playing, seems to keep Firefox smooth. Having to have Edge running in the background forever does not seem like a good long-term solution though.

No longer seems to be an issue on current versions of Windows 10.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.