Closed Bug 1412770 Opened 3 years ago Closed 3 years ago

Port |Bug 1408789 - Use VS2017 for official Windows builds|

Categories

(SeaMonkey :: Build Config, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.55

People

(Reporter: ewong, Assigned: ewong)

Details

Attachments

(1 file, 3 obsolete files)

Use VS2017 for Win32/Win64 builds.
Attached patch [tooltool] add VS2017 manifests (obsolete) — Splinter Review
first step... add vs2017 manifests
Attachment #8923307 - Flags: review?(frgrahl)
Comment on attachment 8923307 [details] [diff] [review]
[tooltool] add VS2017 manifests

Looks good but needs a fix.

rust x86 is the same as x64 in the patch but these are different packages. Please check mail configs.

And do we need a vs2017.manifest or couldn't we just use releng.manifest like TB?

mozconfig.vs-latest has been changed to use VS2017 now.

f+ for now.
Attachment #8923307 - Flags: review?(frgrahl) → feedback+
(In reply to Frank-Rainer Grahl (:frg) from comment #2)
> Comment on attachment 8923307 [details] [diff] [review]
> [tooltool] add VS2017 manifests
> 
> Looks good but needs a fix.
> 
> rust x86 is the same as x64 in the patch but these are different packages.
> Please check mail configs.

Fixed.

> 
> And do we need a vs2017.manifest or couldn't we just use releng.manifest
> like TB?
> 
> mozconfig.vs-latest has been changed to use VS2017 now.

If that's the case, then there's little point in keeping two manifests.


> 
> f+ for now.
Assignee: nobody → ewong
Attachment #8923307 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8923641 - Flags: review?(frgrahl)
We cannot replace vs2015 w/ VS2017 since VS2017 doesn't even build on Win2008r2 in Win32 mode.

So we need https://hg.mozilla.org/try-comm-central/rev/4b4d3ae29fdda9f508160bc8ec314f1aa0232dd5
until we figure out how to build win32 binaries on vs2017 on our loaner.

I'm wondering if we can modify our mozconfigs to not use mozconfig.vs-latest,
but the vs2015 version.
Attachment #8923641 - Attachment is obsolete: true
Attachment #8923641 - Flags: review?(frgrahl)
Attachment #8923753 - Flags: review?(frgrahl)
Attachment #8923753 - Attachment is obsolete: true
Attachment #8923753 - Flags: review?(frgrahl)
Attachment #8923755 - Flags: review?(frgrahl)
Comment on attachment 8923755 [details] [diff] [review]
[tooltool/mozconfig] changes to use vs2017 only for win64

x86 should just build fine on 2008 R2. Did you try? If I understand the comments right TB seems to do win32 builds on XP which shouldn't even have worked on XP with VS2015.
Attachment #8923755 - Flags: review?(frgrahl) → review+
(In reply to Frank-Rainer Grahl (:frg) from comment #8)
> Comment on attachment 8923755 [details] [diff] [review]
> [tooltool/mozconfig] changes to use vs2017 only for win64
> 
> x86 should just build fine on 2008 R2. Did you try? If I understand the
> comments right TB seems to do win32 builds on XP which shouldn't even have
> worked on XP with VS2015.

TB isn't building on XP.  They are building on Windows 2008R2. Afaik, AWS spot
instances don't have XP instances.  I believe the treeherder xp info is not
updated.
Pushed by ewong@pw-wspx.org:
https://hg.mozilla.org/comm-central/rev/b445a09c601f
Use VS2017 for Win32/Win64 build r=frg
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Target Milestone: --- → seamonkey2.55
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.