Closed Bug 1412958 Opened 2 years ago Closed 2 years ago

Thunderbird decision task often fails on hg checkout.

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 58.0

People

(Reporter: tomprince, Assigned: tomprince)

Details

Attachments

(1 file)

The task is failing with errors like:

abort: No such file or directory: '/builds/worker/build/mozilla/testing/mozbase/mozinstall/tests/Installer-Stubs

while checkout the mozilla-central tree.

I think this may be caused by not using the checkout cache as the directory to checkout in.
Comment on attachment 8923536 [details]
Bug 1412958: Use sparse checkout cache for comm-central decision task;

https://reviewboard.mozilla.org/r/194658/#review199690

Asking for m-c review becuase this changes how we interact with caches shared with firefox builds.
Comment on attachment 8923536 [details]
Bug 1412958: Use sparse checkout cache for comm-central decision task;

https://reviewboard.mozilla.org/r/194660/#review201014

This should be fine.

Just watch out for the cache name: it will need to be manually updated whenever we make a backwards incompatible change to run-task's cache handling. Fortunately, this will manifest via task failures effectively due to cache poisoning, so it should be pretty obvious when lapses occur.
Attachment #8923536 - Flags: review?(gps) → review+
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/784d13621189
Use sparse checkout cache for comm-central decision task; r=gps
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 58.0
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/comm-central/rev/9f66c9bd9f63
Sync .taskcluster.yml with mozilla-central; r=me
You need to log in before you can comment on or make changes to this bug.