Closed Bug 1413043 Opened 2 years ago Closed 2 years ago

Various test suites are going to permafail when Gecko 58 merges to Beta on 2017-11-02 due to WebRender asserts

Categories

(Core :: Graphics: WebRender, defect, P1, blocker)

58 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 + verified

People

(Reporter: RyanVM, Assigned: jerry)

References

Details

(Whiteboard: [wr-reserve])

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]: Lots of broken tests on the next merge day.

Not sure yet which of the recent changes to webrender_ffi_generated.h caused this, but it's breaking a number of tests at the moment. The merge to Beta is on Thursday, so this needs attention ASAP.

https://treeherder.mozilla.org/logviewer.html#?job_id=140880543&repo=try&lineNumber=33309

Assertion failure: false (MOZ_ASSERT_UNREACHABLE: WebRender disabled), at /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/webrender/webrender_ffi_generated.h:1481
Flags: needinfo?(hshih)
To reproduce, only the patch below should be required.
https://hg.mozilla.org/try/rev/af2b5e982ed36f1141a1a305f408d1f867ac43bf
Whiteboard: [wr-mvp] [triage]
Bisection on Try is pointing at bug 1399389 as the culprit.

Basically, this blocks me from testing both Linux64 or Windows on Try at the moment (OSX is spared since we cross-compile and therefore can't run the xpcshell self-tests on those builds and Linux32 opt also appears to be OK). If we can't identify a fix for this ASAP, I'll need to backout bug 1399389 instead.
Blocks: 1399389
Other test suites are also affected:
https://treeherder.mozilla.org/logviewer.html#?job_id=140891483&repo=try
Summary: Various xpcshell tests are going to permafail when Gecko 58 merges to Beta on 2017-11-02 due to WebRender asserts → Various test suites are going to permafail when Gecko 58 merges to Beta on 2017-11-02 due to WebRender asserts
Final follow-up, I promise. Mass orange on OSX once the various test suites ran, on both opt and debug builds. I've verified on Try that everything is green again with bug 1399389 backed out.

https://treeherder.mozilla.org/logviewer.html#?job_id=140893384&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=140891906&repo=try
etc...
I'm checking this crash now.
Assignee: nobody → hshih
Status: NEW → ASSIGNED
Flags: needinfo?(hshih)
Duplicate of this bug: 1413028
Priority: -- → P1
Whiteboard: [wr-mvp] [triage] → [wr-reserve]
It looks like I forgot to check the WR enabling status before the WR calls. I'm waiting the try result.
MozReview-Commit-ID: 29mkllmDQ0L
Attachment #8923660 - Flags: review?(howareyou322)
fix typo.
Attachment #8923668 - Flags: review?(howareyou322)
Attachment #8923660 - Attachment is obsolete: true
Attachment #8923660 - Flags: review?(howareyou322)
Attachment #8923668 - Flags: review?(howareyou322) → review+
Flags: needinfo?(howareyou322)
Pushed by hshih@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b9e21d1b0cf
check WR enabling status before the WR calls. r=pchang
https://hg.mozilla.org/mozilla-central/rev/2b9e21d1b0cf
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Hi Ryan,
The try looks good and I tried with this patch locally. I don't see the crash in xpcshell test. Please needinfo again if there is still having the same problem.
Flags: needinfo?(ryanvm)
Duplicate of this bug: 1413028
Today's Try run looks great. Thanks for the quick fix!
Status: RESOLVED → VERIFIED
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.