Closed Bug 1413055 Opened 2 years ago Closed 2 years ago

stylo: Crash when try to open hamburger menu with Style chrome activated

Categories

(Core :: CSS Parsing and Computation, defect, P1)

x86_64
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- disabled

People

(Reporter: github, Assigned: xidorn)

References

Details

(Keywords: nightly-community)

Crash Data

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171030103605

Steps to reproduce:

Open firefox with fresh profile
set layout.css.servo.chrome.enabled to true
restart browser
open the hamburger menu


Actual results:

Firefox crashes


Expected results:

Menu should open and display the menu entries
Blocks: stylo-chrome
Hardware: Unspecified → x86_64
Version: 58 Branch → Trunk
I've been using stylo-chrome for a while, but never seen any crashes, and can't reproduce with a new profile either.
Can you please put the link to crash report?
Flags: needinfo?(github)
Summary: Crash when try to open hamburger menu with Style chrome activated → stylo: Crash when try to open hamburger menu with Style chrome activated
Thanks!  I guess the crash is caused by bug 1374177.
Sounds like stylo-chrome is not usable on Mac at the moment because of the three new internal properties that we didn't added into Stylo. Those should be fixed soon.
Depends on: 1374177, 1374178
Status: UNCONFIRMED → NEW
Ever confirmed: true
Crash Signature: [@ mozalloc_abort | abort | style::gecko::wrapper::{{impl}}::needs_transitions_update ]
OS: Unspecified → Mac OS X
P1 because this crash will block us from enabling stylo-chrome on Mac.
Priority: -- → P1
This will be fixed by bug 1374178 soon.  Assigning to Xidorn.  If that bug did not fix the crash, it's an animation fault, I guess. :)
Assignee: nobody → xidorn+moz
Status: NEW → ASSIGNED
Just tested with Manish on his macOS install, and this happened before upgrading to Nightly 59, but no longer happens after the upgrade, so let's call it fixed!
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.