Remove references to whimsycorn easter egg from beta 57 since it is unreachable

RESOLVED FIXED in Firefox 57

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

57 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed, firefox58 wontfix)

Details

Attachments

(1 attachment)

The whimsycorn easter egg will be unreachable in Firefox 57 thanks to a new menu. The attached patch removes references to it from mozilla-beta 57.

We can have a more thorough clean-up patch for Firefox 58 and beyond. The most important part here is removing the two assets which are about 24kb in size.
Comment hidden (mozreview-request)
See Also: → bug 1410666
This is wontfix for 58. Bug 1410666 will track changes for 58.
status-firefox58: affected → wontfix

Comment 3

a year ago
mozreview-review
Comment on attachment 8923885 [details]
Bug 1413247 - Remove whimsycorn references from #PanelUI since it is unreachable in Firefox57.

https://reviewboard.mozilla.org/r/195042/#review200116

This looks like an easy way of slimming down the 57 build a little bit. Thanks!
Attachment #8923885 - Flags: review?(mconley) → review+
Comment on attachment 8923885 [details]
Bug 1413247 - Remove whimsycorn references from #PanelUI since it is unreachable in Firefox57.

Approval Request Comment
[Feature/Bug causing the regression]: none
[User impact if declined]: slightly larger download/installer size
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: removes CSS and image that are not accessible in 57
[String changes made/needed]: none

try push at https://treeherder.mozilla.org/#/jobs?repo=try&revision=56152144b4281f7bafe97726eb862518d6381b92 (test failures are due to artifact builds being used in try push)
Attachment #8923885 - Flags: approval-mozilla-beta?
Comment on attachment 8923885 [details]
Bug 1413247 - Remove whimsycorn references from #PanelUI since it is unreachable in Firefox57.

Reducing installer size, seems low risk, Beta56+
Attachment #8923885 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 6

a year ago
uplift
https://hg.mozilla.org/releases/mozilla-beta/rev/339cb803bbed
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.