Closed Bug 1413256 Opened 3 years ago Closed 2 years ago

ConstantSourceNode.offset min/max values incorrect

Categories

(Core :: Web Audio, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1476695

People

(Reporter: toy.raymond, Assigned: theo.rabut)

Details

(Keywords: dev-doc-complete, Whiteboard: [need info padenot 2017-11-01])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.18 Safari/537.36

Steps to reproduce:

c = new AudioContext();
n = new ConstantSourceNode(c);
console.log(n.offset.minValue);
console.log(n.offset.maxValue);

(See https://wpt.fyi/webaudio/chrome/the-constantsourcenode-interface/constant-source-basic.html)


Actual results:

The minValue and maxValue are -infinity and +infinity, respectively.  But the latest version of the WebAudio spec says these should be the most-negative and most-positive single-float values.
Component: Untriaged → Web Audio
Product: Firefox → Core
Paul, can you please asses is this is a confirmed problem and what's the priority?
Flags: needinfo?(padenot)
Whiteboard: [need info padenot 2017-11-01]
I'm going to mark this as a P3 because there is no obvious and/or immediate user impact.
Priority: -- → P3
Clearing NI.

Théo, do you want to take this one? Or maybe someone else?
Flags: needinfo?(padenot) → needinfo?(theo.rabut)
(In reply to Paul Adenot (:padenot) from comment #3)
> Clearing NI.
> 
> Théo, do you want to take this one? Or maybe someone else?

Sure. I will work on this.
Flags: needinfo?(theo.rabut)
Assignee: nobody → theo.rabut
Status: UNCONFIRMED → ASSIGNED
Rank: 25
Ever confirmed: true
Comment on attachment 8928221 [details]
Bug 1413256 - ConstantSourceNode.offset min/max values. Most-negative and most-positive single-float instead of -infinity/+infinity.

https://reviewboard.mozilla.org/r/199442/#review204542

Looks good, but this needs a test.
Attachment #8928221 - Flags: review?(padenot)
Comment on attachment 8928221 [details]
Bug 1413256 - ConstantSourceNode.offset min/max values. Most-negative and most-positive single-float instead of -infinity/+infinity.

https://reviewboard.mozilla.org/r/199442/#review207886
Attachment #8928221 - Flags: review?(padenot) → review+
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/autoland/rev/f7b7bdd7b05c
ConstantSourceNode.offset min/max values. Most-negative and most-positive single-float instead of -infinity/+infinity. r=padenot
Flags: needinfo?(padenot) → needinfo?(theo.rabut)
NI to me as well, I don't understand why this particular wpt started running.
Flags: needinfo?(padenot)
Backout by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fe5938f3d59
Backed out changeset 9e946e79283a in order to update the commit message
My fault. This was for bug 1417113.
Flags: needinfo?(theo.rabut)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(padenot)
Resolution: --- → DUPLICATE
Duplicate of bug: 1476695
Docs updated; see bug 1476695 for details.
You need to log in before you can comment on or make changes to this bug.