Firefox Android Beta 57.0 crashes at every launch

RESOLVED DUPLICATE of bug 1411330

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1411330
24 days ago
24 days ago

People

(Reporter: claas, Unassigned)

Tracking

Firefox 57
Unspecified
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

24 days ago
Created attachment 8924009 [details]
adb-logcat.log

I have been using Firefox Beta on Android for more than one year. About two weeks ago (~ 15th October 2017), the app began crashing immediately at every launch, i.e. it has become unusable and I had to use Firefox Nightly meanwhile.

However, I would like to be able to use Firefox Beta again, last but not least because I have several passwords saved in the corresponding profile.

Please find attached the full adb-logcat.log for such a crash. It contains all log messages between the start of Firefox Beta and the start of the Firefox CrashReporter.

What I noticed in the logs:

1. ActivityManager: Scheduling restart of crashed service org.mozilla.fennec/org.mozilla.gecko.customtabs.GeckoCustomTabsService in 1000ms
2. GeckoConsole: Could not read chrome manifest 'file:///data/user/0/org.mozilla.firefox_beta/chrome.manifest'.
3a. GeckoCrashHandler: >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 130386 ("IntentService[GeckoTelemetryUploadSerWorker]").
3b. GeckoCrashHandler: java.lang.IllegalStateException: Expected file to exist but got exception in thread: IntentService[GeckoTelemetryUploadSerWorker]. File info - existence: true, can write: false, size: 739.
3c. GeckoCrashHandler:     at org.mozilla.gecko.telemetry.stores.TelemetryJSONFilePingStore.lockAndReadJSONFromFile(TelemetryJSONFilePingStore.java:242)

Updated

24 days ago
Status: NEW → RESOLVED
Last Resolved: 24 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314835

Comment 2

24 days ago
Actually bug 1411330 might be a better fit, since for you these crashes started happening only with Firefox 57.
Duplicate of bug: 1411330
(Reporter)

Comment 3

24 days ago
Thanks, Jan. Actually, the logs meanwhile helped me to come up with a workaround (because Telemetry upload requires network):

1. Enable flight mode.
2. Open Firefox Beta.
3. Disable Telemetry and Health Report.
4. Close Firefox Beta.
5. Disable flight mode.
6. Open Firefox Beta again.
7. No crash.
(Reporter)

Comment 4

24 days ago
(And this explains why Firefox Beta sometimes actually didn't crash immediately, namely when my phone didn't have a network connection.)
You need to log in before you can comment on or make changes to this bug.