Browser hangs in about:telemetry is not readable

RESOLVED FIXED in Firefox 59

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: 61.1p57, Assigned: o0ignition0o, Mentored)

Tracking

(Blocks: 1 bug)

58 Branch
mozilla59
Points:
---

Firefox Tracking Flags

(firefox58 wontfix, firefox59 fixed)

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Posted image screenshot.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171030103605

Steps to reproduce:

Open about:telemetry, find a ping that has records in "Browser Hangs" section


Actual results:

The 'Sorry! There is currently no data available in “Browser Hangs”' prompt insists on the screen, making the records hard to read.


Expected results:

The prompt should go away if there is data available to display.
Component: Untriaged → Telemetry
Product: Firefox → Toolkit
My guess is that "Browser Hangs" is another section that should be on the search blacklist (a la bug 1396836)
Blocks: 1384534
status-firefox58: --- → wontfix
Priority: -- → P2
Priority: P2 → P1
Chris, can this be a mentored bug?
Flags: needinfo?(chutten)
It certainly can be!

This bug involves: 

0) Volunteering on this bug to help out (at which point I will assign it to you)
1) downloading and building the Firefox source,
2) editing toolkit/content/aboutTelemetry.js to add the chrome-hangs section to the search blacklist (on or around this line https://searchfox.org/mozilla-central/source/toolkit/content/aboutTelemetry.js#1285),
3) then rebuilding and testing that the search bar and "no search results" bear don't show on the Browser Hangs tab any longer.
4) Formatting a commit with a useful commit message, marking me as a reviewer
Mentor: chutten
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(chutten)
Whiteboard: [good first bug][lang=js]
(Reporter)

Comment 4

a year ago
Although I can't verify it myself since I recently moved back to Beta, but IIRC the "Browser Hangs" section is acutally searchable. Do we really want to disable searching altogether just because an error message appeared unintentionally?

BTW, I suppose this also affects the "Late Writes" section as it also shows the "no data available" message
You're probably right. It's been a while since I've seen data in Late Writes or Browser Hangs so I'm not 100% sure what it's supposed to look like.

Maybe it would be better to hide the "Fetch function names for stacks" link in Browser Hangs,Late Writes when there is no data to display.

Comment 6

a year ago
Hi, I can make a start on this bug ASAP.
Wonderful! As mentioned in comment 5, the new step 2 is to ensure the "Fetch function names for stacks" links do not appear when there are no hangs or late writes. That should take care of the overlapping display we're seeing in the attached screenshot.

Please let me know if you have any questions!
Assignee: nobody → mandercs3
Status: NEW → ASSIGNED
Are you still working on this, or should I unassign you from the bug? No worries if you're busy! There are always more bugs for when you have a moment in the future :)
Flags: needinfo?(mandercs3)
(Assignee)

Comment 9

a year ago
Hey there :) I don't know if the bug is still being worked on, but I would love to work on it if it's available ! :)
As it turns out, the search functionality is looking for a table ( https://searchfox.org/mozilla-central/source/toolkit/content/aboutTelemetry.js#1417 ) in order to proceed.

I think the easiest thing to handle this for now would be to disable search altogether in the Late Writes and Browser Hangs pages (I guess it wasn't searchable anyway).

A nice followup would be to format the Late Writes and Browser Hangs in a nice table, and restore a search functionality.

I'll prepare a patch to add Late Writes and Browser Hangs to the search blacklist, and I can followup on this someone can point me to a place where I can find browser hangs and late writes JSON objects to reproduce the output (I used a couple of arrays with random strings to reproduce the bug http://ibb.co/erdsUw ) 

I'm about to submit a patch with two distinct commits (one for Late Writes and one for Browser Hangs)

Oh and a Happy new year ! :)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee: mandercs3 → jeremy.lempereur
Flags: needinfo?(mandercs3)

Comment 13

a year ago
mozreview-review
Comment on attachment 8939259 [details]
Bug 1413448 - Fix about:telemetry "no data available" overlay in the Late Writes section.

https://reviewboard.mozilla.org/r/209688/#review215456

Looks good to me!
Attachment #8939259 - Flags: review?(chutten) → review+

Comment 14

a year ago
mozreview-review
Comment on attachment 8939258 [details]
Bug 1413448 - Fix about:telemetry "no data available" overlay in the Browser Hangs section.

https://reviewboard.mozilla.org/r/209686/#review215458

Looks good to me!
Attachment #8939258 - Flags: review?(chutten) → review+

Comment 15

a year ago
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3af16adba66
Fix about:telemetry "no data available" overlay in the Browser Hangs section. r=chutten
https://hg.mozilla.org/integration/autoland/rev/d4e1ce460135
Fix about:telemetry "no data available" overlay in the Late Writes section. r=chutten
I've sent these to autoland. Thanks for your contribution!

As for example late writes and browser hangs, there's some documentation on the formats available in our in-tree docs: https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/data/main-ping.html#chromehangs

They're some of the less-frequently-used parts of the data, so I wouldn't worry too much about them being searchable.

Comment 17

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b3af16adba66
https://hg.mozilla.org/mozilla-central/rev/d4e1ce460135
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.