Update our current "switch to ESR" prompt version check to include JAWS versions 19 and lower

RESOLVED FIXED in Firefox 57

Status

()

Core
Disability Access APIs
P1
normal
RESOLVED FIXED
23 days ago
17 days ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
mozilla58
All
Windows
Points:
---

Firefox Tracking Flags

(firefox57blocking verified, firefox58 fixed)

Details

(Whiteboard: aes+)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

23 days ago
We just finished up testing of the various JAWS screen readers that are available. We have:

1) older JAWS releases prior to version 18.0.2945, including 17.* versions
2) an updated 18 (18.0.4321) that received various bug fixes 
3) the current beta of JAWS 2018 (19.0.3002)

In general we don't feel enough progress has been made here so we're going to update our version information to include newer releases. Hence, we plan to push JAWS users to ESR 52 rather than keep them on 57.

http://searchfox.org/mozilla-central/source/accessible/windows/msaa/Compatibility.cpp#171
(Assignee)

Updated

23 days ago
status-firefox58: affected → ---
(Assignee)

Comment 1

23 days ago
Hey Ritu, this will require an uplift to 57. It's a very minor change involving JAWS version info. We have a conversation going with the vendor to nail down specific version information, after which we'll post a patch here.
status-firefox57: --- → affected
tracking-firefox57: --- → ?
Flags: needinfo?(rkothari)
(Assignee)

Updated

23 days ago
Priority: -- → P1

Comment 2

23 days ago
Jim, DBolter and I met to discuss the rationale behind this uplift and it's clearly a must fix for 57. Tracked as blocker with the hopes that we'll push the patch in b14 on Friday.
tracking-firefox57: ? → blocking
Flags: needinfo?(rkothari)

Comment 3

23 days ago
Hi Tom, Ryan, if we are not already doing so in ESR smoke testing, consider adding JAWS + ESR52.5 testing to the ESR sign off plans. Especially since some release a11y users will be prompted to go use ESR.
Flags: needinfo?(tgrabowski)
Flags: needinfo?(ryanvm)
(Assignee)

Comment 4

23 days ago
Created attachment 8924246 [details] [diff] [review]
part1 - enable the prompt for jaws version 19 or lower
Assignee: nobody → jmathies
(Assignee)

Updated

23 days ago
Attachment #8924246 - Flags: review?(dbolter)
(Assignee)

Comment 5

23 days ago
Created attachment 8924251 [details] [diff] [review]
part2 - disable jaws esr prompting in nightly so we can test
(Assignee)

Updated

23 days ago
Attachment #8924251 - Flags: review?(felipc)
Sure, we can add that.
Flags: needinfo?(tgrabowski)
Flags: needinfo?(ryanvm)
Flags: needinfo?(andrei.vaida)
(Assignee)

Comment 7

23 days ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ab7ec97e76506c0759e33618f2cc84d1e96a1d7
Attachment #8924251 - Flags: review?(felipc) → review+
Comment on attachment 8924246 [details] [diff] [review]
part1 - enable the prompt for jaws version 19 or lower

Review of attachment 8924246 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, this should work.
Attachment #8924246 - Flags: review?(dbolter) → review+
(Assignee)

Updated

22 days ago
Keywords: checkin-needed

Comment 9

22 days ago
Pushed by jmathies@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5b1cc7fdfa40
Update the 'switch to ESR' prompt minimum version check to include JAWS versions 19 and lower. r=davidb
https://hg.mozilla.org/integration/mozilla-inbound/rev/7043cf41cae4
Disable the JAWS compatibility prompt in Nightly builds for testing. r=felipe
(Assignee)

Updated

22 days ago
Keywords: checkin-needed
(Assignee)

Updated

22 days ago
Whiteboard: aes+
https://hg.mozilla.org/mozilla-central/rev/5b1cc7fdfa40
https://hg.mozilla.org/mozilla-central/rev/7043cf41cae4
Status: NEW → RESOLVED
Last Resolved: 22 days ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Hi Jim, please nominate this for uplift to Beta. I would have liked to include this in b14 which we built yesterday. Since we missed that, this will most likely be included in Desktop RC1 (gtb Monday).
Flags: needinfo?(jmathies)

Comment 12

21 days ago
Pushed by jmathies@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2d9c80e3684
Backed out changeset 5b1cc7fdfa40
https://hg.mozilla.org/integration/mozilla-inbound/rev/24f4d2216af9
Update the 'switch to ESR' prompt minimum version check to include JAWS versions 18 and lower. r=davidb
(Assignee)

Comment 13

21 days ago
Reopening as we're adjusting this version check based on some feedback from Freedom Scientific.
Status: RESOLVED → REOPENED
Flags: needinfo?(jmathies)
Resolution: FIXED → ---
(Assignee)

Comment 14

21 days ago
Created attachment 8925091 [details] [diff] [review]
part1 - enable the prompt for jaws version 18 or lower
Attachment #8924246 - Attachment is obsolete: true
Attachment #8925091 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/d2d9c80e3684
https://hg.mozilla.org/mozilla-central/rev/24f4d2216af9
Status: REOPENED → RESOLVED
Last Resolved: 22 days ago21 days ago
Resolution: --- → FIXED
(Assignee)

Comment 16

20 days ago
Comment on attachment 8925091 [details] [diff] [review]
part1 - enable the prompt for jaws version 18 or lower

Approval Request Comment
[Feature/Bug causing the regression]:
Update version information related to JAWS accessibility client ESR prompting
[User impact if declined]:
Users will not receive the prompt, and potentially run into issues with Firefox.
[Is this code covered by automated tests?]:
no, a11y clients are manual test only.
[Has the fix been verified in Nightly?]:
Yes.
[Needs manual test from QE? If yes, steps to reproduce]: 
Good to have - confirming current JAWS 18 users who manually install 57 receive the prompt on startup with JAWS running.
[List of other uplifts needed for the feature/fix]:
none
[Is the change risky?]:
no
[Why is the change risky/not risky?]:
well understood code
[String changes made/needed]:
none
Attachment #8925091 - Flags: approval-mozilla-beta?
Comment on attachment 8925091 [details] [diff] [review]
part1 - enable the prompt for jaws version 18 or lower

This is a must for 57, we'd like Firefox a11y users on incompatible versions of JAWS to use Firefox ESR52 instead of 57.
Attachment #8925091 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/44eeabf61313 (FIREFOX_57b_RELBRANCH)
https://hg.mozilla.org/releases/mozilla-release/rev/efd2b124b2a8
status-firefox57: affected → fixed
This issue is verified fixed on 57.0-build1 (20171106194249) using Windows 7 x64 and Windows 10 x64. The switch to ESR prompt is received on startup, on 57 manual installation and with JAWS 18 running.
status-firefox57: fixed → verified
Flags: needinfo?(andrei.vaida)
You need to log in before you can comment on or make changes to this bug.