Auto-width floated div is too small

VERIFIED INVALID

Status

()

defect
P3
normal
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: hyp-x, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Example:
  <div style="float:left">Two words</div>

Expected behaviour:
  Wrapping should only occur if the viewport is too narrow to display the text
  in a single line.

Actual behaviour:
  The two words are shown in two lines regardless of the window size.

Regression:
  Occurs on: 1999-09-16-08 apprunner (Win98)
  Doesn't occur on: NS 4.51, IE 4
Posted file Testcase
Assignee: troy → kipp
I think this bug should be marked invalid, unless you want to ignore the CSS
spec for compatibility's sake, which I am against.

CSS2 says (in 10.3.5, I think) that non-replaced floating elements with auto
width should have width 0.  (Note that the rules are different for replaced
elements and that tables act kinda like replaced elements.)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
The css spec is quite clear on how to treat these, and we do the right thing.
Since floating div's aren't really supported in prior nav releases, there is
really no point in getting worked up for compatabilities sake.
Status: RESOLVED → VERIFIED
Based on kipp's comments, markingh as verified invalid.
You need to log in before you can comment on or make changes to this bug.