Closed Bug 141415 Opened 22 years ago Closed 22 years ago

sigsegv at startup under solaris 9

Categories

(SeaMonkey :: General, defect)

Sun
Solaris
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 136144

People

(Reporter: peter.lees, Assigned: Matti)

Details

(Keywords: crash)

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311
BuildID:    20020418

solaris 9 (build 58 shwpl 3) SPARC

mozilla 1.0rc1 crashes with segmentation fault (dumps core) on
startup, before any GUI elements are drawn.

last 30 lines of truss are:
---------------------------------------------------------------------
2268/1:
	open("/usr/ccs/lib/libc.so.1", O_RDONLY)	Err#2 ENOENT
2268/1:
	open("/usr/lib/libc.so.1", O_RDONLY)		= 15
2268/1:
	fstat(15, 0xFFBFCC24)				= 0
2268/1:
	close(15)					= 0
2268/1:
	open("/opt/mozilla-1.0rc1/libw.so.1", O_RDONLY)	Err#2 ENOENT
2268/1:
	open("/opt/mozilla-1.0rc1/plugins/libw.so.1", O_RDONLY) Err#2 ENOENT
2268/1:
	open("/usr/sfw/lib/libw.so.1", O_RDONLY)	Err#2 ENOENT
2268/1:
	open("/usr/lib/libw.so.1", O_RDONLY)		= 15
2268/1:
	fstat(15, 0xFFBFCC24)				= 0
2268/1:
	mmap(0xFE160000, 8192, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED, 15, 0) =
0xFE160000
2268/1:
	resolvepath("/usr/lib/libw.so.1", "/usr/lib/libw.so.1", 1023) = 18
2268/1:
	close(15)					= 0
2268/1:
	open("/opt/mozilla-1.0rc1/libc.so.1", O_RDONLY)	Err#2 ENOENT
2268/1:
	open("/opt/mozilla-1.0rc1/plugins/libc.so.1", O_RDONLY) Err#2 ENOENT
2268/1:
	open("/usr/sfw/lib/libc.so.1", O_RDONLY)	Err#2 ENOENT
2268/1:
	open("/usr/lib/libc.so.1", O_RDONLY)		= 15
2268/1:
	fstat(15, 0xFFBFCC24)				= 0
2268/1:
	close(15)					= 0
2268/1:
	    Incurred fault #6, FLTBOUNDS  %pc = 0xFFE80000
2268/1:
	      siginfo: SIGSEGV SEGV_MAPERR addr=0xFFE80000
2268/1:
	    Received signal #11, SIGSEGV [default]
2268/1:
	      siginfo: SIGSEGV SEGV_MAPERR addr=0xFFE80000
2259:
waitid(P_PID, 2268, 0xFFBFE710, WEXITED|WTRAPPED|WNOWAIT) = 0
2259:
ioctl(0, TIOCGPGRP, 0xFFBFE6CC)			= 0
2259:
ioctl(0, TCGETS, 0x000391D4)			= 0
2259:
waitid(P_PID, 2268, 0xFFBFE710, WEXITED|WTRAPPED) = 0
2259:
write(2, " S e g m e n t a t i o n".., 33)	= 33
2259:
brk(0x0003E520)
				= 0
2259:
brk(0x0003E320)
				= 0
2259:
_exit(139)
---------------------------------------------------------------------


mozilla 0.9.9 2002031103 works *FINE* under same conditions of libraries, etc
(using it now)



Reproducible: Always
Steps to Reproduce:
1. install mozilla in /opt/mozilla as root
2. as root, run 

MOZILLA_FIVE_HOME=/opt/mozilla
LD_LIBRARY_PATH=/opt/mozilla:/opt/gnome-1.4/lib:/usr/sfw/lib
export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
echo "using LD_LIBRARY_PATH = $LD_LIBRARY_PATH"
/opt/mozilla/regxpcom
/opt/mozilla/regchrome
touch /opt/mozilla/chrome/user-skins.rdf /opt/mozilla/chrome/user-locales.rdf

(this completes ok)

3. log on as user, execute /opt/mozilla/mozilla

Actual Results:  $ /opt/mozilla/mozilla
Segmentation Fault - core dumped
$

Expected Results:  mozilla should have started & kept running!
Keywords: crash
Summary: sigsegv at startup under solaris 9 → sigsegv at startup under solaris 9
dup of bug 136144?
looks like a dup to me, so i'll close it in deference to the prior bug report.

*** This bug has been marked as a duplicate of 136144 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: