Change of Theme not loaded upon restart

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Aurele Venet, Assigned: shliang)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc1) Gecko/20020418
BuildID:    2002041818

I try to select a new theme (one that worked with mozilla 0.9.9, build
2002031103). It tells me that I need to restart the browser.  upon restarting I
get the following error message in my xterm.

Gdk-CRITICAL **: file gdkgc.c: line 51 (gdk_gc_new_with_values): assertion
`window != NULL' failed.


The new theme has not been loaded, and instead I get the classic theme.

Furthermore, the dynamic theme change menu 'Apply Theme', found under the 'View'
menu is not available anymore in this build compared to the previous one.

Reproducible: Always
Steps to Reproduce:
1.In Preferences change appearance/theme selection to something else. 
2.Quit mozilla, and restart it.  New theme not loaded
3.

Actual Results:  Same appearance as intial launch, ie the Classic theme 

Expected Results:  According to mozilla 0.9.9, look & feel should have changed

Updated

16 years ago
Whiteboard: DUPEME
(Reporter)

Comment 1

16 years ago
I start mozilla with the mail client first.  The original bug report refers to
my attempts at changing the theme from the mail client using a version of a
theme that was for the mozilla 0.9.9.  I now realise that the 'Apply theme' menu
is still available from the browser window.  I have noted 2 things:

1.  I can successfully change the theme from the browser window 'Apply theme'
menu.  The original error (when applied from the mail client) was due to the
fact that I was trying to apply a mozilla 0.9.9 theme to a mozilla 1.0rc1 build.
 When I tried to change the theme from the browser window, an error message
window correctly pointed out that I was trying to apply a theme that was meant
for v0.9.9. I have now downloaded the new version of the theme and this works fine.

2.  The 'apply theme' menu theme change was dynamic in v0.9.9, i.e. it was not
required to restart mozilla in order to see the changes.  This is not the case
anymore.

Apologies if this update in the bug report comes in a few hours after the
original report.  
which theme did you try? does the problem still exist with Mozilla 1.1beta and a
recent version of the theme?

Comment 3

16 years ago
Invalid?

Comment 4

16 years ago
Looks like this is WORKSFORME..., based on Arueles own comments (comment #1).

Dynamic theme switching was disabled for a while ago. Bug 134260 tracks the work
to enable this feature again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.