Remote display to Solaris kills X-server

VERIFIED FIXED

Status

()

defect
P2
critical
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: cullrich, Assigned: mcafee)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Overview Description:
Mozilla crashes when started on a pc-linux from a sun-classic.
Steps to Reproduce:
1.)Logon on a sun-classic
2.)Rlogon on a pc with linux (SuSE_5.2)
3.)Start mozilla on the PC
4.)Open any menus.

Actual Results: The sun classic crashes:
   The window manager is closed, the login prompt is presented.
   No keyboard input is accepted, but login from another maschine
   on the sun is still possible. The linux-pc is unaffected.

Expected Results: Opening of the menus.

Build Date & Platform: The binary of Milestone 9 for linux

Additional Builds and Platforms: none tested
Assignee: don → mcafee
Priority: P3 → P2
Target Milestone: M13
Chris, check this out later if you get a chance.  I don't think it's a beta
blocker.
Component: Browser-General → Layout
Summary: Mozilla crashes when started on a pc-linux from a sun-classic → Remote display to Solaris kills X-server
resummarizing, cc-ing akkana who saw something like this last week.
The X server crash I was seeing (in mail/news under Xaccel on Linux) was
possibly due to a much-too-long string being sent to the X server, or something
like that.  There was a bug (now fixed) in mailnews which caused the contents of
an entire mailbox to be displayed as one very long line, and that crashed
Xaccel.  That bug was 19996.
QA Contact: leger → petersen
Updating QA Contact.
Target Milestone: M13 → M15
bug in Solaris X-server, not m13
Move to M16 for now ...
Target Milestone: M15 → M16
Target Milestone: M16 → M18
Move to M21 target milestone.
Target Milestone: M18 → M21
Do we know which X server this user was using?

Ill check it out with a solaris box at work tommrow, but I'm guessing this is
some crufty X server that needs to be tracked down to play with.
I think I saw this on Solaris 2.6, a long time ago.
This is technically not a mozilla bug, but a bug in
the X-servers.  We should make an attempt to fix this,
but it's not a show-stopper for mozilla.
Just for the sake of completeness, I'll note that whatever X server a brand-new
Ultra-10 uses has no problems with the given scenario. In fact, Moz runs great
like that, even over ssh and a few network segments.
pavlov says this is fixed, and I see it working for me,
linux display to solaris 2.6/8-bit
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Based on the previous comments, marking verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.