Closed Bug 1414249 Opened 2 years ago Closed 2 years ago

Provide way to disable Heartbeat Firefox rating survey

Categories

(Shield :: Heartbeat, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: poiru, Unassigned)

Details

The "Please rate Firefox" heartbeat surveys are incredibly annoying and look suspicious. The survey[0] itself looks like it's from 1995. I've gotten the rating prompt 3 times in just the last two days on Firefox beta.

The instructions[0] to disable Heartbeat do not work.

[0]: https://qsurvey.mozilla.com/s3/Beta-activity-stream-survey-1?b=variant&source=heartbeat&surveyversion=56&updateChannel=beta&fxVersion=57.0&isDefaultBrowser=1&searchEngine=ddg&syncSetup=1&utm_source=firefox&utm_medium=show-heartbeat&utm_campaign=PleaseRateFirefox&type=stars&score=5&flowId=5b905760-fab9-104c-a6a5-c43264d1208f
[1]: https://support.mozilla.org/en-US/kb/rate-your-firefox-experience-heartbeat
Flags: needinfo?(glind)
Flags: needinfo?(MattN+bmo)
Summary: Disabling Heartbeat Firefox rating survey → Provide way to disable Heartbeat Firefox rating survey
I was only involved in reviewing the initial UI code which has now been removed. Redirecting to Matt_G
Flags: needinfo?(MattN+bmo) → needinfo?(mgrimes)
Component: Tours → Heartbeat
Product: Firefox → Shield
The instructions on Sumo are out of date. The correct preference to change extensions.shield-recipe-client.enabled.

However, the fact that you've seen this more than once in a few days implies there is a bug. We try hard to avoid prompting users very often. Can you share some details about your system so that we can figure out the root cause here? Do you have any extensions or other programs that may be clearing data between restarts?
Flags: needinfo?(mgrimes) → needinfo?(jsavage)
The only extension I have is uBlock Origin. I clear unwhitelisted cookies on restart, but that should be it.

Note that I just pressed "X" for the latest prompts, but I did gave a rating a week or two ago.
The article has been updated with the correct pref. Thanks, Alice!
Flags: needinfo?(jsavage)
Alright, I think we can go ahead and close this bug in that case. Thanks all!
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(glind)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.