Closed Bug 1414277 Opened 2 years ago Closed 1 year ago

Audio/Video delay present on very long recordings

Categories

(Core :: Audio/Video: Recording, defect, P3)

58 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1423253
Tracking Status
firefox58 --- wontfix
firefox66 --- wontfix
firefox67 --- fix-optional
firefox68 --- verified

People

(Reporter: aflorinescu, Unassigned)

References

Details

[Environments:]
Mac OsX 10.12
Windows 10 (x64)
Windows 7 (x64)
58.0a1 	20171103100331


[Steps:]
1. Open Firefox.
2. Go to: https://jsfiddle.net/pehrsons/7kgvL48e/
3. Select/Check the Video box (square box) and Select Video Source - Screen (circle box) - in the right side of the page
4. Select/Check the Audio box (square box) and Select Audio Source - Microphone (circle box) - in the right side of the page
5. Setup the environment: 
-camera to point at the screen and mic/headphones to go together.
-open http://youtubeonrepeat.com/watch/?v=FqpwNycAdQY
6. Press Start button.
7. Leave the recording going for a long period of time. (20h+)
8. Stop the recording (after the long recording)

[Expected Result:]
There is no A/V delay.

[Actual Result:]
On Windows 7 and 10, there is a delay noticeable, after 10hrs ~3-50ms, after 19h ~1s, after 25h ~2s.

On OSX, the delay is slightly less noticeable and seems constant along the entire video recording(~0.5s). Weird enough, we didn't notice this delay on the test short recordings.

We didn't manage to test this on Ubuntu, we ran out of space and due to time constrains, we couldn't redo the test.

( delay = the audio is lagging behind video )

[Expected Result:]
Audio/Video stays synced during the entire recording.
Rank: 25
Priority: -- → P3

As of bug 1423253 this should now work without any drift. Adrian, I don't suppose you could re-test this? :-)

Flags: needinfo?(adrian.florinescu)

(In reply to Andreas Pehrson [:pehrsons] from comment #1)

As of bug 1423253 this should now work without any drift. Adrian, I don't suppose you could re-test this? :-)

'll let the test run over the weekend. I assume there's no rush verifying this.

(In reply to Adrian Florinescu [:adrian_sv] from comment #2)

I assume there's no rush verifying this.

Not at all!

redo the NI when we can try again to verify.

Flags: needinfo?(adrian.florinescu)

Bug 1542685 landed. Verifying now should be more successful!

Flags: needinfo?(adrian.florinescu)

Finally managed to verify it, Windows 10 Pro x 64, 68.0a1 20190502220333 :

-webm recording totaling 69:49:51 / 74GB

All looking good and synced on Fx68.

Flags: needinfo?(aflorinescu)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423253
You need to log in before you can comment on or make changes to this bug.