Recognise well-understood platform names

RESOLVED DUPLICATE of bug 1470646

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1470646
2 years ago
10 months ago

People

(Reporter: ato, Unassigned, Mentored)

Tracking

(Blocks 1 bug, {good-first-bug})

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=rust], )

Reporter

Description

2 years ago
When matching capabilities [1], the WebDriver specification encourages us to recognise “well-understood” platform names such as "windows", "mac", and "linux".  Currently, if Marionette/Firefox returns "windows_nt" we perform an equality match on this string.

According to the note in the specification it is fine for geckodriver to return a more specific platformName capability with that value, but we should be lenient in what platform names we accept as input.  As I understand it, this means we should accept "windows" as input if the current system is roughly Windows equivalent, and then return "windows_nt" (or whatever else the system gives us) as the negotiated platformName.

  [1] https://w3c.github.io/webdriver/webdriver-spec.html#dfn-matching-capabilities
Reporter

Comment 1

2 years ago
With the above in mind, I think it is highly suspect to implement something from the specification that is in a note.  As I understand we are not bound to implement the more lenient platformName matching because it is not normative, but it would be “nice” of us to do so.

James, I trust you share my concerns about this particular note in the specification.  My opinion is that if something is to be implemented by a driver for sake of backwards compatibility it should be called out explicitly, and not in a note.  Do you have any recommendation how we can improve the spec situation for the future?
Flags: needinfo?(james)
On master, not on the Rec branch, define what's meant by "more specific" and move it out of a note. For example is it any substring match? I think the reason it's in a note is that no one wants to detail what actually happens here, but we should probably just figure out what remote ends (as opposed to e.g. grid, which can do whatever it  likes) actually do.
Flags: needinfo?(james)
Reporter

Updated

2 years ago
Duplicate of this bug: 1421233
Severity: normal → critical
Priority: -- → P1
Reporter

Updated

a year ago
Mentor: ato
Keywords: good-first-bug
Priority: P1 → P2
Whiteboard: [lang=rust]
Reporter

Updated

a year ago
Blocks: webdriver
Reporter

Updated

a year ago
Severity: critical → normal
What is to be done for this bug?  I'd like to work on this.
Flags: needinfo?(ato)
Reporter

Comment 5

10 months ago
Oh sorry, it looks like I fixed this in
https://bugzilla.mozilla.org/show_bug.cgi?id=1470646 but forgot to
close this bug.
Flags: needinfo?(ato)
Reporter

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1470646
You need to log in before you can comment on or make changes to this bug.