Closed Bug 1414439 Opened 5 years ago Closed 4 years ago

Eliminate calls to nsIXPConnect::GetCID()

Categories

(Core :: XPCOM, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1489147

People

(Reporter: mccr8, Unassigned)

References

Details

Attachments

(1 file)

This is used to get a pointer to nsIXPConnect, but there are better ways to do that.
Depends on: 1414441
Depends on: 1414442
Assignee: continuation → nobody
Here's my WIP. I think it needs some cleaning up, and probably rebasing after all this time.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1489147
You need to log in before you can comment on or make changes to this bug.