Closed Bug 1414508 Opened 5 years ago Closed 2 years ago

Crash in mozilla::SmallPointerArray<T>::Length

Categories

(Core :: Web Painting, defect, P2)

55 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-cd7dfe1f-75c9-4251-b707-4eff20171021.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::SmallPointerArray<mozilla::DisplayItemData>::Length() 	obj-firefox/dist/include/mozilla/SmallPointerArray.h:139
1 	xul.dll 	mozilla::RestyleManager::AddLayerChangesForAnimation(nsIFrame*, nsIContent*, nsStyleChangeList&) 	layout/base/RestyleManager.cpp:1768
2 	xul.dll 	mozilla::ElementRestyler::Restyle(nsRestyleHint) 	layout/base/GeckoRestyleManager.cpp:1913
3 	xul.dll 	mozilla::GeckoRestyleManager::RestyleElement(mozilla::dom::Element*, nsIFrame*, nsChangeHint, mozilla::RestyleTracker&, nsRestyleHint, mozilla::RestyleHintData const&) 	layout/base/GeckoRestyleManager.cpp:228

this is a low volume crash regression across platforms since firefox 55 looking related to the changes in bug 1331718.
Priority: -- → P2

RestyleManager is no longer on the Stack, of only 3-4 crashes in past three months of recent versions. Probably can be closed?
https://crash-stats.mozilla.org/signature/?signature=mozilla%3A%3ASmallPointerArray%3CT%3E%3A%3ALength&date=%3E%3D2020-10-11T11%3A51%3A00.000Z&date=%3C2021-01-11T11%3A51%3A00.000Z

Flags: needinfo?(matt.woodrow)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.