Crash on Facebook Messenger 2017-11-04

RESOLVED DUPLICATE of bug 858032

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 858032
2 years ago
a year ago

People

(Reporter: iiiiikolor, Unassigned)

Tracking

({crash, crashreportid})

58 Branch
Points:
---

Firefox Tracking Flags

(firefox57 ?, firefox58 affected)

Details

(crash signature)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171104100412

Steps to reproduce:

Hello O would like noticed today I tried use Facebook messenger but firefox 4 times crash.I can't use it.I have to install chrome .Bottom links for crash . 



Actual results:

https://crash-stats.mozilla.com/report/index/c761ca81-7e83-4c6a-81c3-674830171104

https://crash-stats.mozilla.com/report/index/108689fa-12b0-4792-aa79-917a20171104

https://crash-stats.mozilla.com/report/index/910feb96-6856-48c0-99fb-67b6f0171104

https://crash-stats.mozilla.com/report/index/12a944f0-8590-4536-bb01-58b010171104
Crash Signature: [@ EnterJit ]
Component: Untriaged → JavaScript Engine: JIT
Keywords: crash, crashreportid
Product: Firefox → Core
Summary: Facebook messenger 2017-11-04 → Crash on Facebook Messenger 2017-11-04
pawel, thank you for the bug report.

Jan, there doesn't appear to be much to go on here. Could you take a look?

Do we know about the increase in crashes @EnterJIT (I know, maximally vague signature) around October 15?
Flags: needinfo?(jdemooij)
Priority: -- → P1
I looked at some of the JIT crashes. They look like different/random memory corruption. Also, not all of the crashes are JIT crashes, for instance:

https://crash-stats.mozilla.com/report/index/910feb96-6856-48c0-99fb-67b6f0171104
https://crash-stats.mozilla.com/report/index/26f83218-ddcd-4739-aa21-d9bea0171104

Given the frequency for the reporter, and Facebook being one of the most popular websites, I doubt this is a JIT bug.

pawel, can you try running MemTest overnight?
Flags: needinfo?(jdemooij)
The recent spike seems to be only happening in Firefox 58.0a1 based on crash reports.

pawel, can you please confirm if this happens in Firefox 57 (currently in Beta)?
Flags: needinfo?(iiiiikolor)
Reporter

Comment 5

2 years ago
I have Firefox 58 I tied call to my friend and I see windows open .This happen when he answered and he call to me and I answered .

If somebody has a Facebook account we can tied do this as see crash .
Flags: needinfo?(iiiiikolor)
(In reply to pawel from comment #5)
> I have Firefox 58

Sorry, that doesn't answer my question. Can you please download and install Firefox 57 from beta.mozilla.org and see if this crash happens in that version?
Reporter

Comment 7

2 years ago
This happen when you call for someone at messenger Facebook.

How I check this .I need someone who will answered my call.Then I will see Firefox crash or not .

Comment 10

a year ago
Hi, I am currently using Firefox 59.2 and am seeing similar crashes, though not on Facebook (seems to be any site).

https://crash-stats.mozilla.com/report/index/bp-f751a092-56e0-4c08-babc-789710180422
https://crash-stats.mozilla.com/report/index/bp-59a8d48a-0754-4808-b343-2cf0f0180422
https://crash-stats.mozilla.com/report/index/bp-e928b701-eabf-4563-9fb5-b7ed30180422

Firefox crashes frequently, maybe hourly, and I'm at a loss as to what the problem is. Firefox is the only thing that appears to have any stability issues on this system, so I would suspect something like bad memory to cause machine-wide issues. Nevertheless, I will run a memtest on this to see if I can rule that out.
Kevin, Where you able to get a memtest result? Looking at some your crashes it appears you are experiencing single-bit memory errors. I've observed similar on other Ryzen machines that have ended up having thermal issues. I'm not sure what sort of stress tests people run these days.
Flags: needinfo?(kevin)
Whiteboard: [#jsapi:crashes-retriage]
Original issues here seem to be related to memory problems. We weren't able to reproduce Facebook Messenger specific issues so closing in favour of meta-bug.

(Kevin, feel free to answer my questions here)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Whiteboard: [#jsapi:crashes-retriage]
Duplicate of bug: SadJit

Comment 13

a year ago
Ted,

Tl,dr: bad DIMM

Ha. Sorry I forgot to update this bug with my results. After attaching WinDbg and finally getting WinDbg to break at the right time on the right process, I observed as you described. I Removed all DIMMs but one, and added them back one at a time until I identified a DIMM that was not functioning properly.

Since removing that DIMM I have experienced zero crashes after weeks of use.

Interestingly, memtest86 passed. After running it twice with the bad DIMM, it failed the second time. I find it curious that Firefox was able to reproduce the issue frequently while every other peice of software on the machine functioned fine, as far as I could tell. I didn't look into that too much.
Flags: needinfo?(kevin)
I appreciate the update :)
You need to log in before you can comment on or make changes to this bug.