hang when selecting text and right-clicking on page

VERIFIED FIXED

Status

()

Core
String
--
critical
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Olivier Cahagne, Assigned: jag (Peter Annema))

Tracking

({hang, regression, testcase})

Trunk
x86
All
hang, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build ID: 2002043008 on Win2k and 2002043027 on Linux (both trunk).

Steps to reproduce:
1. Load URL http://www.w3.org/Style/CSS
2. Select text 'CSS is a simple mechanism etc.' until end of line,
3. Right click on page (can be on the selected text or any other part of page),
4. Mozilla hangs, if it does not hang, select more text and right-click,

Doesn't happen on build 2002042807 on Linux.
So, this is a regression between 20020428 and 20020430. Didn't find this bug
reported before. Related though: bug 141309, bug 141312.
(Reporter)

Updated

16 years ago
Keywords: hang, regression
(Reporter)

Comment 1

16 years ago
Created attachment 81847 [details]
Testcase: select text and right-click -> hang
(Reporter)

Updated

16 years ago
Keywords: testcase
(Reporter)

Comment 2

16 years ago
While hanging, CPU jumps to 99%.

Comment 3

16 years ago
*** Bug 141456 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
The duplicate is on Windows XP.
Confirmed, noticed it first yesterday.

Linux, too.

Can someone please confirm?

Comment 6

16 years ago
2002043010 on Win2k too --- 2002042708 works

mozilla hangs too, when selecting text in a usenet-message and clicking with the
rightmouse button.

Comment 7

16 years ago
Hang also occurs when selecting text and starting to drag it.  Not specific to
right-clicking.
#7: ACK

But I cannot remember the exact steps to reproduce, but I'm almost sure that I
did not right-click.

Comment 9

16 years ago
Can´t reproduce this bug with:
WIN98 and Mozilla 1.0 Release Candidate 2 (Windows; U; Win98; en-US; rv:1.0rc2)
Gecko/20020430

I follow the steps to reproduce the bug under different cirumstances, in the
newsreader, mailwriter and in the browser. 

Comment 10

16 years ago
Also hangs for me with 2002050108/Win98SE if I try to mark text.
So... why is this assigned to "String" ?
*** Bug 141498 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

16 years ago
Boris: because I had no idea what component to choose. Bug 141312 is assigned to
'String', might be better to reassign to 'Editor:Core' as in bug 141309.
And I was afraid of leaving a bug in 'General', which would never get enough
attention.
(Assignee)

Comment 14

16 years ago
Created attachment 81909 [details] [diff] [review]
Don't feed really large lengths to Mid or Substring.

Comment 15

16 years ago
Comment on attachment 81909 [details] [diff] [review]
Don't feed really large lengths to Mid or Substring.

sr=alecf
Attachment #81909 - Flags: superreview+

Comment 16

16 years ago
Comment on attachment 81909 [details] [diff] [review]
Don't feed really large lengths to Mid or Substring.

r=akkana
Attachment #81909 - Flags: review+
(Assignee)

Comment 17

16 years ago
When alecf moved |Left|, |Mid| and |Right| into nsCString and nsString, the 
|Substring| code that it ended up calling changed from the one that acts on 
|nsAString|s to the (cheaper) one that acts on |nsASingleFragmentString|s. The 
latter Substring code doesn't deal as nicely (it shouldn't have to) with passing 
in negative (or, cast to unsigned, really large) numbers, which is what exposed 
the bug in this code.

Checked in, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: mozilla1.0
Resolution: --- → FIXED
*** Bug 141645 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
URI still (or again)hangs with 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020501
Hang is confirmed by several people in de.comm.software.mozilla (Jens Müller, ...) 

Reopen?  Regression?
Rainer, your Mozilla does not have the fix yet. Use a build from today.
Confirming that the bug is fixed in 2002050209 (Trunk).
*** Bug 141823 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
verified fixed using 2002050204 on Windows.  Tried it first with yesterday's
build before I read the whole bug and I definitely hung.
Status: RESOLVED → VERIFIED

Comment 24

16 years ago
*** Bug 141788 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
*** Bug 141810 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
Reply to #20
Confirming that bug has been fixed in
Mozilla 1.0.0+
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020502
*** Bug 142242 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 28

16 years ago
*** Bug 141312 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 29

16 years ago
*** Bug 142780 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 30

16 years ago
*** Bug 143044 has been marked as a duplicate of this bug. ***
*** Bug 142780 has been marked as a duplicate of this bug. ***
Are alecf's string changes landing on branch?  If so, we need to land this on
branch too...
You need to log in before you can comment on or make changes to this bug.