Address fields stop working after deletion of address in first address field

VERIFIED DUPLICATE of bug 134729

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 134729
16 years ago
10 years ago

People

(Reporter: Luke Plant, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Overview:  When composing a message with more than one address field filled in,
if the top one is deleted so that all the others shift up, the address fields no
longer allow addition of more addresses, and the e-mail can't be sent (Mozilla
complains that no recipients are specified)

Steps to reproduce:
1.  Compone new e-mail
2.  Type any address in the first address box, press enter
3.  Type a second address in the second box, press enter
4.  Repeat step three as many times as you want, or none
5.  Importantly, then press backspace, so that the blank line you were on
disappears, and you move up a line.  There should be no blank fields which have
a 'To/CC/Bcc' box to the left of them.

Alternatively, steps 1-5 can be replaced by simply doing a 'reply all' on a
message with more than one recipient.

6.  Click in the first address field, and delete its contents.
7.  Press delete once more so that the list of addresses below all move up

Result:
1.  You can no longer add more addresses in the normal way.  Pressing enter at
the end of the line doesn't add another blank line.  If the list of e-mail
addresses is more than one line long (i.e. more than one address), then you can,
however, still add more addresses by clicking on the blank line below the last
address.

2.  You can't send the e-mail either - Mozilla seems to think there are no
recipients specified

Comment 1

16 years ago
Please always include build ID in bug-reports.
Resolving as duplicate of bug 134729. This should be fixed in builds from Apr.
23rd outwards.

*** This bug has been marked as a duplicate of 134729 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
QA Contact: esther → laurel
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.