Closed Bug 1414632 Opened 2 years ago Closed 2 years ago

Crash in webrtc::Merge::SignalScaling

Categories

(Core :: WebRTC: Audio/Video, defect, P1, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jseward, Assigned: dminor)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-1b6b5cfb-6b6b-4753-9d6a-42fff0171102.
=============================================================

This is topcrash #17 in the Windows nightly 20171102100041.
It is reported as an integer division by zero.
Flags: needinfo?(rjesup)
Rank: 15
Priority: -- → P2
We divide by mod_input_length in the line just above the one causing the crash [1], perhaps that calculation is being inlined on line 219 causing the error to be reported there. If mod_input_length is zero, then it looks like either the input buffer length is zero, or the input sampling frequency is zero.

[1] https://hg.mozilla.org/mozilla-central/annotate/515407ebfa14/media/webrtc/trunk/webrtc/modules/audio_coding/neteq/merge.cc#l218
First crash is in the 10/30 Nightly.  All earlier crashes (2) are a different issue with (probably) negative energy.  So we should look at what's new in 10/30.  All are windows
Flags: needinfo?(rjesup)
Also: since this is a new regression, I'm moving this to p1 - we shouldn't ship new regressions we find during nightly.
Rank: 15 → 8
Priority: P2 → P1
Dan, since all P1's need an owner and you took an initial look can I ask you to continue to investigate taking Randell's observations into account?
Let me know if you want me to find another owner.
Assignee: nobody → dminor
Flags: needinfo?(dminor)
Just a thought: if the code hasn't changed in the date range have we already switched to a new Visual Studio version (I remember seeing something regarding VS 2017 on a mailing list) which compiles the code differently?
Sure, I'll have a look.
Flags: needinfo?(dminor)
Attachment #8926540 - Flags: review?(rjesup) → review+
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e47ee65540ba
Prevent division by zero in webrtc::Merge::SignalScaling; r=jesup
https://hg.mozilla.org/mozilla-central/rev/e47ee65540ba
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
We should upstream this fix.
You need to log in before you can comment on or make changes to this bug.