Stop button no longer appears immediately after starting a navigation

VERIFIED FIXED in Firefox 57

Status

()

VERIFIED FIXED
a year ago
a year ago

People

(Reporter: JanH, Assigned: JanH)

Tracking

({regression})

Firefox 57
Firefox 58
All
Android
regression
Points:
---

Firefox Tracking Flags

(fennec+, firefox56 unaffected, firefox57+ verified, firefox58 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Previously, the stop button appeared immediately after clicking a link, together with the progress bar showing up and indicating minimal progress.

Currently, the progress bar appears immediately just a before, but the stop button only shows up after the navigation got as far as a location change.
This means that at the moment you can no longer cancel a page load before we've already navigated away from the old page.
(Assignee)

Comment 1

a year ago
Out of https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=892c8916ba32b7733e06bfbfdd4083ffae3ca028&tochange=2306e153fba9ca55726ffcce889eaca7a479c29f it's almost certainly bug 1366672.
Blocks: 1366672
status-firefox56: --- → unaffected
status-firefox57: --- → fix-optional
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

a year ago
[Tracking Requested - why for this release]: User can no longer abort a page load until it gets as far as "location change".
Assignee: nobody → jh+bugzilla
tracking-firefox57: --- → ?
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Version: Trunk → Firefox 57
Attachment #8925633 - Flags: review?(snorp) → review?(cnevinchen)
Tracking for 57 for now, but since this is marked fix-optional it won't show up on some of release managment's (and other) queries. 
If you land this on m-c and the tests pass, and you still think we need to fix it for 57, please request uplift.
tracking-firefox57: ? → +
(Assignee)

Comment 5

a year ago
Marking it as affected for now then.
status-firefox57: fix-optional → affected

Comment 6

a year ago
mozreview-review
Comment on attachment 8925633 [details]
Bug 1414838 - Show stop button again as soon as page loading starts.

https://reviewboard.mozilla.org/r/196744/#review202052
Attachment #8925633 - Flags: review?(cnevinchen) → review+

Comment 7

a year ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/e46ec8edd9ba
Show stop button again as soon as page loading starts. r=nechen

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e46ec8edd9ba
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox58: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(Assignee)

Comment 9

a year ago
Comment on attachment 8925633 [details]
Bug 1414838 - Show stop button again as soon as page loading starts.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1366672
[User impact if declined]: After starting a page load, users cannot cancel it again until the load gets as far as locationchanges (or else eventually times out).
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Verified locally.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This simply restores the old behaviour of updating the toolbar state on starting a page load as well.
[String changes made/needed]:
Attachment #8925633 - Flags: approval-mozilla-beta?
Comment on attachment 8925633 [details]
Bug 1414838 - Show stop button again as soon as page loading starts.

57 is on m-r now.
Attachment #8925633 - Flags: approval-mozilla-beta? → approval-mozilla-release?
Ioana, can you verify this fix in nightly?
Flags: needinfo?(ioana.chiorean)

Comment 12

a year ago
Verified as fixed on the latest Beta (58.0b3/build 4) and the latest Nightly (59.0a1 / 2017-11-14)
This issue was tested on a Pixel C (Android 8.0)
status-firefox58: fixed → verified
Flags: needinfo?(ioana.chiorean)
tracking-fennec: ? → +
Comment on attachment 8925633 [details]
Bug 1414838 - Show stop button again as soon as page loading starts.

Fix a recent regression and didn't cause any regression for now, taking it.
Attachment #8925633 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 15

a year ago
Verified as fixed on RC 57.0.1.
Device: Samsung Galaxy Tab 3 (Android 7.0)
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.