Closed Bug 1414977 Opened 2 years ago Closed 2 years ago

New vertex attrib validation with robust_buffer_access_behavior (RBAB) causes DrawElements to fail

Categories

(Core :: Canvas: WebGL, defect, P1, critical)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 + fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

()

Details

(Whiteboard: gfx-noted)

Attachments

(3 files)

No description provided.
Assignee: nobody → jgilbert
Priority: -- → P2
This exhibits with angle disabled, and triangles fail to draw. Turning webgl.force-index-validation:true causes everything to draw again.
Comment on attachment 8925748 [details]
Bug 1414977 - Skip DrawElements if !indexCount, not !lastVert. -

https://reviewboard.mozilla.org/r/196908/#review202066

lgtm. Thanks!
Attachment #8925748 - Flags: review?(dmu) → review+
Duplicate of this bug: 1414996
Since this was a huge regression for Linux, we absolutely need a test for it. I needed to make the pref trinary in order to test it, though. (1 means force-validation, -1 means force-skip-validation, 0 means default behavior)
[Tracking Requested - why for this release]: Moving tracking flag over from the duplicate bug.
Comment on attachment 8925770 [details]
Bug 1414977 - Add test for drawing without index validation. -

https://reviewboard.mozilla.org/r/196944/#review202092

lgtm!
Attachment #8925770 - Flags: review?(dmu) → review+
Comment on attachment 8925769 [details]
Bug 1414977 - Allow webgl.force-index-validation:-1 to disable index validation for testing. -

https://reviewboard.mozilla.org/r/196942/#review202094

r=me. thanks!
Attachment #8925769 - Flags: review?(dmu) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c0a66ad2d873
Allow webgl.force-index-validation:-1 to disable index validation for testing. - r=daoshengmu
https://hg.mozilla.org/integration/mozilla-inbound/rev/25856ffb9083
Add test for drawing without index validation. - r=daoshengmu
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2580222abc7
Skip DrawElements if !indexCount, not !lastVert. - r=daoshengmu
Severity: normal → critical
Priority: P2 → P1
Whiteboard: gfx-noted
Blocks: 1414524
Summary: New vertex attrib validation with skipping index validation can cause drawing to fail → New vertex attrib validation with robust_buffer_access_behavior (RBAB) causes DrawElements to fail
You need to log in before you can comment on or make changes to this bug.