Selecting lines containing <BR> tag and right-clicking hangs browser (100% CPU usage)

RESOLVED DUPLICATE of bug 141455

Status

()

Core
Selection
--
critical
RESOLVED DUPLICATE of bug 141455
16 years ago
16 years ago

People

(Reporter: doctor__j, Assigned: mjudge)

Tracking

({hang})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

190 bytes, text/html
Details
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020430
BuildID:    2002043010

When you make word selection which spans to two lines or more, and
right-clicking to bring up the context menu, you will have 100% CPU usage and
Mozilla hangs...

Reproducible: Always
Steps to Reproduce:
1. Load the testcase.
2. Make word selection such that the selection spans into two lines or more.
3. Right click to bring up the context menu.

Actual Results:  100% CPU usage and Mozilla hangs.

Expected Results:  Context menu pops up.

Probably the <br> tag in between two lines choked the menu item "Web search for
%s" in context menu.
(Reporter)

Comment 1

16 years ago
Created attachment 81860 [details]
Testcase

Updated

16 years ago
Keywords: hang

Comment 2

16 years ago
Dupe of bug 141455?

pi

*** This bug has been marked as a duplicate of 141455 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.