Headers -> Request URL is trimmed to origin only

RESOLVED FIXED in Firefox 58

Status

defect
P2
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: jryans, Assigned: gasolin)

Tracking

({regression})

Trunk
Firefox 58
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 unaffected, firefox58- fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
The change in bug 1251836 wanted to remove the fragment identifier from the URL shown in the Headers tab, but in doing so, it trimmed the request URL to the origin only, dropping the path as well.

For the URL "https://www.synology.com/css/syno.css?bob=true#foo":

ER: Request URL should say: "https://www.synology.com/css/syno.css?bob=true"
AR: Request URL says: "https://www.synology.com"
Reporter

Updated

2 years ago
Flags: needinfo?(gasolin)
Flags: needinfo?(abhinav.koppula)
Reporter

Updated

2 years ago
Assignee

Comment 1

2 years ago
Looks like I miss interpret the requirements...

could solve with `url.split("#")[0]` instead of `new URL().origin`
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: needinfo?(gasolin)
Priority: -- → P2
Reporter

Updated

2 years ago
Flags: needinfo?(abhinav.koppula)
Comment hidden (mozreview-request)
Comment on attachment 8925795 [details]
Bug 1414981 - Request URL should not show #hash;

https://reviewboard.mozilla.org/r/196978/#review202202

Looks good, thanks Fred!

Can we have a test for this?
(preferable extending an existing test if possible)

Honza
Attachment #8925795 - Flags: review?(odvarko)
Comment hidden (mozreview-request)
Comment on attachment 8925795 [details]
Bug 1414981 - Request URL should not show #hash;

https://reviewboard.mozilla.org/r/196978/#review202876

Looks good and the test is green when testing locally.
R+
Thanks Fred!

Honza
Attachment #8925795 - Flags: review?(odvarko) → review+
Comment hidden (mozreview-request)
Assignee

Comment 7

2 years ago
fixed eslint issue and try green now, thanks!

Comment 8

2 years ago
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffd79ce93abd
Request URL should not show #hash;r=Honza

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ffd79ce93abd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.