Closed Bug 1414996 Opened 2 years ago Closed 2 years ago

[Linux] Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black), and other WebGL demos don't render either

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1414977
Tracking Status
firefox57 --- unaffected
firefox58 - fix-optional

People

(Reporter: dholbert, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

STR:
 1. Visit https://www.google.com/maps/@37.5861732,-122.3595805,636m/data=!3m1!1e3

ACTUAL RESULTS:
Map is entirely black (with some labels visible,but no mapping/satellite imagery)

EXPECTED RESULTS:
Satellite/map data should be visible.

I'm testing using Ubuntu 17.10 64-bit, on a ThinkPad P50, with up-to-date Nightly.


This is a recent regression, from Bug 1404196.  Regression range from mozregression:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33221afe200c3caa8a35b41f104637644b6becf3&tochange=f9baf7fe5e8170b88934f59c46e4913fa013bb0e
Requesting tracking58, because this is a recent regression which ideally we should avoid shipping to Beta58 users when the release trains switch in a week.
Flags: needinfo?(jgilbert)
Summary: Google Maps "Satellite View" doesn't work → Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black)
This might be Linux-specific -- Jet tested on Mac, and he gets satellite imagery showing up there.

As for my machine -- I'm testing using a fresh Firefox profile, and I'll post my about:support graphics info in a minute.  

Also: it looks like WebGL is just entirely broken for me, as a result of this regression.  Simpler demo: http://madebyevan.com/webgl-water/
This demo renders the nice ball-in-water animation in builds before this regression (e.g. Nightly 2017-11-01) but that demo area is just black for me after the regression (e.g. Nightly 2017-11-02)
Summary: Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black) → Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black), and other WebGL demos don't render either
Attachment #8925738 - Attachment description: about:support "graphics" section, from my affected Linux P50 machine → about:support "graphics" section, from my affected Linux ThinkPad P50 machine
Sorry, previous attachment was missing some stuff for mysterious reasons. Reposting.

I verified that this about:support Graphics data (the attachment I'm posting now) is *100% the same*, in a Nightly build from just before the regression (11-01), a build from the first day of the regression (11-02), and today's Nightly (11-06).
Attachment #8925738 - Attachment is obsolete: true
Attachment #8925738 - Attachment description: about:support "graphics" section, from my affected Linux ThinkPad P50 machine → (incomplete copypaste of my about:support graphics data; disregard)
(This works fine in Win10 on the same ThinkPad P50 device, BTW. Given that and Comment 3, looks like this is indeed Linux-specific.)
Summary: Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black), and other WebGL demos don't render either → [Linux] Google Maps "Satellite View" mapping/satellite imagery is missing (entirely black), and other WebGL demos don't render either
No longer blocks: 1404196
Depends on: 1404196
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1414977
Moved tracking flags over the dupe bug and updating tracking flags in this one.
You need to log in before you can comment on or make changes to this bug.