A blank icon is displayed after renaming and updating Firefox

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: oana.botisan, Unassigned)

Tracking

Trunk
All
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected, firefox58 affected, firefox59 ?)

Details

Attachments

(1 attachment)

[Affected versions]:
I tested with these versions, but I am sure that others are effected too.
- beta 55.0b2
- beta 56.0b7
- beta 57.ob9

[Affected platforms]:
- Windows 8.1 x 32

[Steps to reproduce]:
1. Install beta 57.0b9
2. Rename the shortcut on the Desktop (for example "test")
3. Update to beta 57.0b14
4. Observe Firefox icon on the Desktop.

[Expected result]:
- Firefox icon is displayed.

[Actual result]:
- Blank icon is displayed.

[Regression range]:
- I don't think this is a regression. I think this occurs because of the renaming of the browser from "Mozilla Firefox" to "Firefox". 

[Additional notes]:
- For more information, please look at the attachment.
I still haven't been able to reproduce this. My current plan is to simplify the code used in bug 1413295 to hopefully make it more reliable and less likely to affect icons.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.