Youtube 4k is not working

RESOLVED DUPLICATE of bug 1414596

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1414596
13 days ago
12 days ago

People

(Reporter: Gurpreet Singh, Unassigned)

Tracking

58 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 days ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171106100122

Steps to reproduce:

Open any YouTube 4k video(30fps and 60fps both) in Firefox Nightly. Play the video. Video will be working for few seconds after that video will freeze but sound will be working. Also I tried with Firefox beta, 4k works flawlessly.


Actual results:

Video freezes


Expected results:

Should be working properly.
(Reporter)

Updated

13 days ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

12 days ago
Please provide a testcase link to "any YouTube 4k video" to make sure we're discussing the same thing.
Flags: needinfo?(kakar.shanky)
(Reporter)

Comment 2

12 days ago
(In reply to Gurpreet Singh from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0)
> Gecko/20100101 Firefox/58.0
> Build ID: 20171106100122
> 
> Steps to reproduce:
> 
> Open any YouTube 4k video(30fps and 60fps both) in Firefox Nightly. Play the
> video. Video will be working for few seconds after that video will freeze
> but sound will be working. Also I tried with Firefox beta, 4k works
> flawlessly.
> 
> 
> Actual results:
> 
> Video freezes
> 
> 
> Expected results:
> 
> Should be working properly.

Test link- https://www.youtube.com/watch?v=0wCC3aLXdOw&t=435s
Flags: needinfo?(kakar.shanky)
(Reporter)

Comment 3

12 days ago
(In reply to Andre Klapper from comment #1)
> Please provide a testcase link to "any YouTube 4k video" to make sure we're
> discussing the same thing.

Test Link - https://www.youtube.com/watch?v=0wCC3aLXdOw&t=435s

Updated

12 days ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1414596
Hi Gurpreet,
Can you check if this bug is gone with the latest Nightly?
(Reporter)

Comment 6

12 days ago
(In reply to Blake Wu [:bwu][:blakewu] from comment #5)
> Hi Gurpreet,
> Can you check if this bug is gone with the latest Nightly?

Hi Blake, Still choppy and lot of frame drops. Would sometimes freeze for 1-2 seconds. Same video in both Chrome and Edge works fine. Tried with both graphic cards also, Intel 530 and Nvidia 960m. Also tried in safe mode. Same result. Also works great in Firefox Beta.

Thanks
(Reporter)

Comment 7

12 days ago
(In reply to Gurpreet Singh from comment #6)
> (In reply to Blake Wu [:bwu][:blakewu] from comment #5)
> > Hi Gurpreet,
> > Can you check if this bug is gone with the latest Nightly?
> 
> Hi Blake, Still choppy and lot of frame drops. Would sometimes freeze for
> 1-2 seconds. Same video in both Chrome and Edge works fine. Tried with both
> graphic cards also, Intel 530 and Nvidia 960m. Also tried in safe mode. Same
> result. Also works great in Firefox Beta.
> 
> Thanks

Also this problem is only on 4k 60fps.

Test link - https://www.youtube.com/watch?v=R3AKlscrjmQ&t=288s
You need to log in before you can comment on or make changes to this bug.