Closed Bug 1415259 Opened 2 years ago Closed 2 years ago

Update strings for 33 locales (4 added locales) for 57 activity stream

Categories

(Firefox :: New Tab Page, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

Attachments

(1 file)

Was waiting on bug 1411797 for a decision to turn off or keep on activity stream. We are now confirmed shipping, so let's get in the strings that were only localized during the 57 beta cycle.
Maybe not… apparently the last locale update was November 1st to catch the last beta.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
To add some more details:
* Nov 1st is indeed the deadline to accept (sign off) new localized strings in Beta. That's to allow for one more beta after the last sign-off.
* Locales work on Nightly, where AS is updated weekly, so I expect these strings to be tested. Also, we have SUMO articles being written, and some QA resources are coming from that front (I know for a fact that it happened for German and Italian).

Updating localization still sounds like a win to me.
Comment on attachment 8926038 [details]
Bug 1415259 - Update strings for 33 locales (4 added locales) for 57 activity stream.

https://reviewboard.mozilla.org/r/197268/#review202964
Attachment #8926038 - Flags: review?(khudson) → review+
Comment on attachment 8926038 [details]
Bug 1415259 - Update strings for 33 locales (4 added locales) for 57 activity stream.

Approval Request Comment
[Feature/Bug causing the regression]: Missing locales in Activity Stream strings
[User impact if declined]: Missing locales.  Some locales will see some English strings
[Is this code covered by automated tests?]: no (it's just strings - no code)
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only changes strings
[String changes made/needed]: It's all strings from translators
Attachment #8926038 - Flags: approval-mozilla-beta?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(In reply to Tim Spurway [:tspurway] from comment #5)
> [Has the fix been verified in Nightly?]: Yes
The strings have been in nightly 58, but this specific patch has not been in mozilla-central and should land directly to 57. This is because the format of how activity stream exports strings is different between 57 and 58.
Status: REOPENED → ASSIGNED
Comment on attachment 8926038 [details]
Bug 1415259 - Update strings for 33 locales (4 added locales) for 57 activity stream.

As per the thread, taking it to 57!
Attachment #8926038 - Flags: approval-mozilla-beta? → approval-mozilla-release+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(In reply to Tim Spurway [:tspurway] from comment #5)
> [Is this code covered by automated tests?]: no (it's just strings - no code)
> [Has the fix been verified in Nightly?]: Yes
> [Needs manual test from QE? If yes, steps to reproduce]: No

This does not need manual testing per Tim.
Flags: qe-verify-
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.