Build Linux/Gtk+ with titlebar rendering enabled

RESOLVED FIXED in Firefox 59

Status

enhancement
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla59
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
We have all patches landed so we can build Gtk+ with CAN_DRAW_IN_TITLEBAR=1

The titlebar rendering is still disabled by "widget.allow-client-side-decoration" preference.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Assignee: nobody → stransky
Summary: Define CAN_DRAW_IN_TITLEBAR for Gtk+ → Build Linux/Gtk+ with titlebar rendering enabled

Comment 4

2 years ago
mozreview-review
Comment on attachment 8926313 [details]
Bug 1415481 - set browser.tabs.drawInTitlebar to true unix platforms,

https://reviewboard.mozilla.org/r/197598/#review202852
Attachment #8926313 - Flags: review+

Comment 5

2 years ago
mozreview-review
Comment on attachment 8926314 [details]
Bug 1415481 - make widget.allow-client-side-decoration visible,

https://reviewboard.mozilla.org/r/197600/#review202854
Attachment #8926314 - Flags: review+

Comment 6

2 years ago
mozreview-review
Comment on attachment 8926312 [details]
Bug 1415481 - Define CAN_DRAW_IN_TITLEBAR for Gtk+ builds,

https://reviewboard.mozilla.org/r/197596/#review202856
Attachment #8926312 - Flags: review+

Comment 7

2 years ago
mozreview-review
Comment on attachment 8926312 [details]
Bug 1415481 - Define CAN_DRAW_IN_TITLEBAR for Gtk+ builds,

https://reviewboard.mozilla.org/r/197596/#review203182
Attachment #8926312 - Flags: review?(mh+mozilla) → review+

Comment 8

2 years ago
mozreview-review
Comment on attachment 8926313 [details]
Bug 1415481 - set browser.tabs.drawInTitlebar to true unix platforms,

https://reviewboard.mozilla.org/r/197598/#review203184

::: browser/app/profile/firefox.js:472
(Diff revision 1)
>  pref("browser.tabs.tabClipWidth", 140);
>  pref("browser.tabs.tabMinWidth", 76);
> -#ifdef UNIX_BUT_NOT_MAC
> -pref("browser.tabs.drawInTitlebar", false);
> -#else
>  pref("browser.tabs.drawInTitlebar", true);

Shouldn't this only me true if CAN_DRAW_IN_TITLEBAR is set?
Attachment #8926313 - Flags: review?(mh+mozilla)

Comment 9

2 years ago
mozreview-review
Comment on attachment 8926314 [details]
Bug 1415481 - make widget.allow-client-side-decoration visible,

https://reviewboard.mozilla.org/r/197600/#review203186
Attachment #8926314 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 10

2 years ago
mozreview-review
Comment on attachment 8926313 [details]
Bug 1415481 - set browser.tabs.drawInTitlebar to true unix platforms,

https://reviewboard.mozilla.org/r/197598/#review203286

::: browser/app/profile/firefox.js:472
(Diff revision 1)
>  pref("browser.tabs.tabClipWidth", 140);
>  pref("browser.tabs.tabMinWidth", 76);
> -#ifdef UNIX_BUT_NOT_MAC
> -pref("browser.tabs.drawInTitlebar", false);
> -#else
>  pref("browser.tabs.drawInTitlebar", true);

CAN_DRAW_IN_TITLEBAR is not a global one and it's not defined here...we'd need to add it for this dir or move it to a global config.
(Assignee)

Comment 11

2 years ago
mozreview-review
Comment on attachment 8926313 [details]
Bug 1415481 - set browser.tabs.drawInTitlebar to true unix platforms,

https://reviewboard.mozilla.org/r/197598/#review203690

::: browser/app/profile/firefox.js:472
(Diff revision 1)
>  pref("browser.tabs.tabClipWidth", 140);
>  pref("browser.tabs.tabMinWidth", 76);
> -#ifdef UNIX_BUT_NOT_MAC
> -pref("browser.tabs.drawInTitlebar", false);
> -#else
>  pref("browser.tabs.drawInTitlebar", true);

I added the CAN_DRAW_IN_TITLEBAR define to browser/app as the global define will need more (potentialy intrusive) work.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 14

2 years ago
Dau, can you please check the updated patch at https://reviewboard.mozilla.org/r/197598/diff/2/ ? It confuses me that I attached a new one but mozreview keeps to show r+ there. Thanks!
Flags: needinfo?(dao+bmo)
(Assignee)

Updated

2 years ago
Attachment #8926313 - Flags: review?(mh+mozilla)
(In reply to Martin Stránský [:stransky] from comment #14)
> Dau, can you please check the updated patch at
> https://reviewboard.mozilla.org/r/197598/diff/2/ ? It confuses me that I
> attached a new one but mozreview keeps to show r+ there. Thanks!

Looks good. Reading browser.tabs.drawInTitlebar should be guarded by CAN_DRAW_IN_TITLEBAR, so imho the original patch was fine too.
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 16

2 years ago
Okay, Thanks!

Comment 17

2 years ago
mozreview-review
Comment on attachment 8926313 [details]
Bug 1415481 - set browser.tabs.drawInTitlebar to true unix platforms,

https://reviewboard.mozilla.org/r/197598/#review204636
Attachment #8926313 - Flags: review?(mh+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 18

2 years ago
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 685393f0e8be -d 32de83b016c9: rebasing 434022:685393f0e8be "Bug 1415481 - Define CAN_DRAW_IN_TITLEBAR for Gtk+ builds, r=dao,glandium"
merging toolkit/modules/moz.build
warning: conflicts while merging toolkit/modules/moz.build! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 22

2 years ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/53463889cdb6
Define CAN_DRAW_IN_TITLEBAR for Gtk+ builds, r=dao,glandium
https://hg.mozilla.org/integration/autoland/rev/4d8dc538cb2d
set browser.tabs.drawInTitlebar to true on windows, cocoa and gtk3 widgets, r=dao,glandium
https://hg.mozilla.org/integration/autoland/rev/a00865a5bd43
make widget.allow-client-side-decoration visible, r=dao,glandium
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 26

2 years ago
Let's try the simple patch which enables browser.tabs.drawInTitlebar for all platforms.
Flags: needinfo?(stransky)

Comment 27

2 years ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/2e814a8043d8
Define CAN_DRAW_IN_TITLEBAR for Gtk+ builds, r=dao,glandium
https://hg.mozilla.org/integration/autoland/rev/d27dcb603c19
set browser.tabs.drawInTitlebar to true unix platforms, r=dao,glandium
https://hg.mozilla.org/integration/autoland/rev/63224d6e543c
make widget.allow-client-side-decoration visible, r=dao,glandium
(In reply to Martin Stránský [:stransky] from comment #26)
> Let's try the simple patch which enables browser.tabs.drawInTitlebar for all
> platforms.

That sounds wrong.

Comment 30

a year ago
I get spaces in both sides of my tab bar. After maximizing the left one disappears but the right one is still there. Setting  browser.tabs.drawInTitlebar to false removes both. Is this expected behaviour?

I'm on Arch Linux, with the Awesome WM.

Updated

a year ago
Depends on: 1418829
(Assignee)

Comment 32

a year ago
(In reply to Johann Hofmann [:johannh] from comment #31)
> Screenshots showing the added drag space:
> 
> https://screenshots.mattn.ca/compare/?oldProject=mozilla-
> central&oldRev=e070277ec199fa96fa490ed52d33646a376d0d80&newProject=mozilla-
> central&newRev=60b9fa15e4272bb1d2b876235f346587be6f2424&filter=linux
> 
> I guess that's intended to be shown by default.

Thanks. Let's solve that at Bug 1418829.

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.