Closed Bug 1415491 Opened 2 years ago Closed 2 years ago

New content is displayed only on the second new tab

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 59
Iteration:
59.4 - Jan 15
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- verified

People

(Reporter: cmuresan, Assigned: ursula)

References

Details

Attachments

(2 files)

[Affected versions]:
- Firefox 58.0a1 Build ID 20171106100122

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Create a new profile and start the browser.
2. Visit 50 different pages. (from www.reddit.com/r/news)
3. Open a new tab and observe the page.
4. Open another new tab and observe the page.

[Expected results]:
- Step 4 & 5: New content is displayed on the page.

[Actual results]:
- Step 4: Default content is displayed.
- Step 5: New content is displayed.

[Notes]:
- Attached a screen recording of the issue.
This is by design. The first tab you open is "cached" so that we can make it available faster.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
We've been doing this ever since Activity Stream entered Nightly, when we didn't cache anything.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Wrong bug, was meant for the other one.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WONTFIX
I still have a question about this behavior: did caching land with bug 1410541?
Flags: needinfo?(andrei.br92)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Flags: needinfo?(andrei.br92)
Assignee: nobody → usarracini
Status: REOPENED → ASSIGNED
Iteration: --- → 1.25
Depends on: 1420285
Duplicate of this bug: 1421437
Iteration: 1.25 → 1.26
Iteration: 1.26 → 59.4 - Jan 15
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/a796d224f97b53162dd0774091d19364c76e703c
Fix Bug 1415491 - New content is displayed only on the second new tab  (#3928)

* Fix Bug 1415491 - New content is displayed only on the second new tab

* Update tests
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Blocks: 1430218
Blocks: 1430272
Blocks: 1397243
I have reproduced this bug with Nightly 58.0a1 (2017-11-08) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta 59.0b3 !

Build   ID    20180122192913
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

[bugday-20180117]
Marking as verified based on comment 9.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.