Closed Bug 1415676 Opened 2 years ago Closed 1 year ago

Assertion failure: inframes == aFrames (Some frames will be dropped) [@ mozilla::AudioConverter::ResampleAudio]

Categories

(Core :: Audio/Video: Playback, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- wontfix

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(1 file)

Attached video testcase.webm
Assertion failure: inframes == aFrames (Some frames will be dropped), at /src/dom/media/AudioConverter.cpp:279

#0 mozilla::AudioConverter::ResampleAudio(void*, void const*, unsigned long) /src/dom/media/AudioConverter.cpp:273:3
#1 unsigned long mozilla::AudioConverter::Process<float>(mozilla::AlignedBuffer<float, 32>&, float const*, unsigned long) /src/obj-firefox/dist/include/AudioConverter.h:219:16
#2 mozilla::AudioDataBuffer<(mozilla::AudioConfig::SampleFormat)6, float> mozilla::AudioConverter::Process<(mozilla::AudioConfig::SampleFormat)6, float>(mozilla::AudioDataBuffer<(mozilla::AudioConfig::SampleFormat)6, float>&&) /src/obj-firefox/dist/include/AudioConverter.h:135:7
#3 mozilla::media::AudioSink::NotifyAudioNeeded() /src/dom/media/mediasink/AudioSink.cpp:436:23
#4 mozilla::detail::RunnableMethodImpl<mozilla::detail::Listener<bool>*, void (mozilla::detail::Listener<bool>::*)(), true, (mozilla::RunnableKind)0>::Run() /src/obj-firefox/dist/include/nsThreadUtils.h:1192:13
#5 mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run() /src/obj-firefox/dist/include/mozilla/TaskDispatcher.h:209:37
#6 mozilla::TaskQueue::Runner::Run() /src/xpcom/threads/TaskQueue.cpp:246:12
#7 nsThreadPool::Run() /src/xpcom/threads/nsThreadPool.cpp:228:14
#8 non-virtual thunk to nsThreadPool::Run() /src/xpcom/threads/nsThreadPool.cpp:156:15
#9 nsThread::ProcessNextEvent(bool, bool*) /src/xpcom/threads/nsThread.cpp:1037:14
#10 NS_ProcessNextEvent(nsIThread*, bool) /src/xpcom/threads/nsThreadUtils.cpp:513:10
#11 mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) /src/ipc/glue/MessagePump.cpp:334:20
#12 MessageLoop::RunInternal() /src/ipc/chromium/src/base/message_loop.cc:326:10
#13 MessageLoop::Run() /src/ipc/chromium/src/base/message_loop.cc:299:3
#14 nsThread::ThreadFunc(void*) /src/xpcom/threads/nsThread.cpp:425:11
#15 _pt_root /src/nsprpub/pr/src/pthreads/ptthread.c:216:5
#16 start_thread (/lib/x86_64-linux-gnu/libpthread.so.0+0x76b9)
#17 clone /build/glibc-bfm8X4/glibc-2.23/misc/../sysdeps/unix/sysv/linux/x86_64/clone.S:109
Flags: in-testsuite?
INFO: Last good revision: 3baaa616310062e7f024a016fcf817a4c4dd451c
INFO: First bad revision: aecaa85bb1d9d8b7d2cbd9ab84eb6dbc0ed9eee8
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3baaa616310062e7f024a016fcf817a4c4dd451c&tochange=aecaa85bb1d9d8b7d2cbd9ab84eb6dbc0ed9eee8
Blocks: 1400674
Has Regression Range: --- → yes
Flags: needinfo?(jwwang)
Version: 58 Branch → 57 Branch
Is this bug still relevant?
Flags: needinfo?(suro001) → needinfo?(jyavenard)
can no longer reproduce... likely because we no longer use the AudioConverter under normal case.
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jyavenard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.