Firefox on GNOME creates duplicate icons; missing WM_CLASS

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
13 days ago
13 days ago

People

(Reporter: imyxhuang, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 days ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171105133105

Steps to reproduce:

On the latest firefox-trunk package from the PPA, 58.0a1 (2017-11-05) (64-bit), the firefox-trunk.desktop file doesn't specify a WM_CLASS.


Actual results:

Because of this, Nightly uses up two icons on the gnome dash/dock. One that has the appropriate icon, but never has windows, and another that is of WM_CLASS "Nightly" and can't be added to favorites because it doesn't have a desktop file of its own. 


Expected results:

A quick fix to this is to add StartupWMClass=Nightly to /usr/share/applications/firefox-trunk.desktop: all the windows are now in the same class, and thus only use one icon.
If you keep WM_CLASS as firefox, you can use --class command line option.

Also, this issue should fix firefox-trunk.desktop.  So we should file a bug to Ubuntu PPA team.
s/we should file a bug to Ubuntu PPA team/you should file a bug to Ubuntu PPA team for Firefox package/
https://help.ubuntu.com/community/ReportingBugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.