If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail Notification Icon does not refresh after mail is checked

VERIFIED DUPLICATE of bug 138095

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED DUPLICATE of bug 138095
16 years ago
9 years ago

People

(Reporter: Dominic, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Quicklaunch icon doesn't refresh after checking mail.  It simply states the last
number of emails on server.  When mouseover is displayed it only maintains the
first count of email.  Also, once mail is checked the Attention Icon doesn't
change out or vanish.

Reproducible: Always
Steps to Reproduce:
1.Open mail application
2.Go to another window and keep focus on new window
3.When Quicklaunch icon appears as Yellow Sign with exclamation point it will
not refresh after checking mail.

Actual Results:  See description

Expected Results:  The Icon should either change to a different quicklaunch icon
or vanish entirely until new mail is detected.

I am using the normalized theme that came with the download, I've not changed
skins or altered the preset conditions with the exception of pop-up windows from
within a current window, which I have turned off.
(Reporter)

Comment 1

16 years ago
Once new mail is received, however, the icon seems to refresh.  It appears that
the problem only occurs on the program's first open until new mail is received.

Comment 2

16 years ago
This is not a Quicklaunch icon, the yellow triangle with exclamation is a mail
notification icon.  Removing QuickLaunc Icon from summary and replacing it with
Mail Notification Icon.  Changing qa to stephend, this may be a dup of a bug
stephen has.
QA Contact: olgam → stephend
Summary: Quicklaunch Icon does not refresh after mail is checked → Mail Notification Icon does not refresh after mail is checked
POP3?  IMAP?  Also, can you try a later build?

The way it's designed is, we leave the icon until you double click the tasktray
icon (opening a the account which has mail in a window), click on a new message,
or click the Get Msgs button.
Also, what do you mean by 'refresh'?  Are you talking about it going away, or
the new message count updating?  If the latter, we have a DUP of that.  (filed
by me)
Related / DUP bugs - bug 134745 and bug 138095
->mail notification owners (scott and me)
Assignee: sspitzer → mscott
Component: Mail Window Front End → Mail Notification

Comment 7

16 years ago
Dupe of bug 146707? There are countless bugs like this.

pi
Duping to your 1st issue 'when mouseover is displayed it only maintains the
first count of email'.

For any additional issues, search bugzilla's Component 'Mail Notification'.

bug 138095

*** This bug has been marked as a duplicate of 138095 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.