Closed Bug 1415784 Opened 2 years ago Closed 2 years ago

Firefox stops rendering images if too many tabs with large images are open; only (correctly-sized) black boxes are displayed

Categories

(Firefox for Android :: General, defect)

Firefox 56
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1380649

People

(Reporter: DavJCobb, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171024165158

Steps to reproduce:

Open several tabs, each of which contains a large image. A combination of search and work pages on art sites like deviantART or Pixiv should be enough for those purposes, though I've had the bug trigger outside of deliberate stress-testing.

Device used is a Samsung Galaxy S5.

Specific stress test: Go to Pixiv's mobile site <pixiv.net>. Open all ten of the artwork pages linked on its home page (four in a 2x2 grid; then six in a 3x2 grid below that; the links further below are articles, not art) in new tabs, such that you have eleven total tabs. One-by-one, go to the Tabs menu and switch to each of the ten new tabs in the order they were opened. Then, switch back to the first of those ten (i.e. your second open tab). On my device, the bug is immediately apparent at that point and affects the first six or so tabs, including the original Pixiv homepage.

When I ran this test, I had saved browser tabs in my main session and ran the test in Private Mode; only one saved tab was loaded (being initially focused on startup). I ran the test twice with different websites (each with different performance costs) in that saved tab, and the exact same Pixiv pages opened as part of the test. Upshot of this is, maybe you need to open twelve art pages, or fifteen. Experiment.


Actual results:

After I browse through, and switch through, enough tabs, Firefox starts failing to display images. Instead, the browser displays properly-sized black boxes, which implies that it's perfectly capable of loading the images, but simply refuses to display them. (Moreover: if a broken image is "above the fold," then going to the Tabs menu will show transparent -- not black -- portions in the thumbnail.) Though a number of large images are needed to actually trigger the bug, almost any image on the page can be affected (e.g. thumbnails hyperlinked to other artwork, given my suggested repro steps).

Refreshing a tab fixes its images, at the obvious cost of redownloading, reparsing, and reprocessing the entire containing page and possibly the images themselves.


Expected results:

Firefox for Android should be reliably capable of displaying pictures that are on the Internet.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380649
You need to log in before you can comment on or make changes to this bug.