cloud.goog not in public suffix list

RESOLVED FIXED in Firefox 58

Status

()

defect
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: daleharvey, Assigned: daleharvey)

Tracking

unspecified
mozilla59
Points:
---

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox57 wontfix, firefox58+ fixed, firefox59 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

Assignee

Description

2 years ago
A friend asked me to look into this, https://hg.mozilla.org/mozilla-central/log/tip/netwerk/dns/effective_tld_names.dat hasnt been updated since 2015 and doesnt contain many recent additions to the public suffix list. 

Looking at http://searchfox.org/mozilla-central/search?q=effective_tld_names.dat&case=false&regexp=false&path= not 100% certain its actually being used anyway
Assignee

Comment 1

2 years ago
Gerv as the last committer is this something you know about, should we do another manual update from github?

Cheers
Assignee: nobody → dharvey
Flags: needinfo?(gerv)
So, this is a bit of a whoopsie :-( We should have had a process for importing this regularly :-(( Yes, please import from Github.

I'm pretty sure it's being used, though - us not using it would be very odd given how many web platform features depend on it.

Gerv
Flags: needinfo?(gerv)
effective_tld_names.dat is by some python that generates etld_data.inc, which is used in http://searchfox.org/mozilla-central/source/netwerk/dns/nsEffectiveTLDService.cpp#27.
Comment hidden (mozreview-request)

Updated

2 years ago
Priority: -- → P5
Whiteboard: [necko-triaged]

Updated

2 years ago
See Also: → 1416247
Comment on attachment 8926868 [details]
Bug 1415870 - Update psl list and related tests.

Looks fine, but of course I can't check each individual change. If we are importing the new file entirely, that's right.

Gerv
Attachment #8926868 - Flags: review?(gerv) → review+
Assignee

Comment 6

2 years ago
Yup it was just a full replacement, cheers

Comment 7

2 years ago
[Tracking Requested - why for this release]:

We'll want to make sure this makes 58, I think, to ensure we get some testing on it before shipping the updates with 59 esr.
Assignee

Comment 8

2 years ago
Gerv any chance you could r+ this in mozreview? easier to autoland than to push directly

Comment 10

2 years ago
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/173578b3688f
Update PSL to latest version from github. r=gerv
Backed out for failing XPCshell's netwerk/test/unit/test_psl.js:

https://hg.mozilla.org/integration/autoland/rev/d35e162abc88cf9cf1adf73b488099c1f54da3e8

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=173578b3688ffcb4c0715023fe992a5d9cf512e4&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=144600788&repo=autoland

[task 2017-11-14T16:16:51.186Z] 16:16:51     INFO -  TEST-PASS | netwerk/test/unit/test_psl.js | checkPublicSuffix - [checkPublicSuffix : 35] "test.ac" == "test.ac"
[task 2017-11-14T16:16:51.187Z] 16:16:51     INFO -  TEST-PASS | netwerk/test/unit/test_psl.js | checkPublicSuffix - [checkPublicSuffix : 35] null == null
[task 2017-11-14T16:16:51.195Z] 16:16:51  WARNING -  TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_psl.js | checkPublicSuffix - [checkPublicSuffix : 35] "c.il" == null
[task 2017-11-14T16:16:51.196Z] 16:16:51     INFO -  /builds/worker/workspace/build/tests/xpcshell/tests/netwerk/test/unit/test_psl.js:checkPublicSuffix:35
[task 2017-11-14T16:16:51.197Z] 16:16:51     INFO -  /builds/worker/workspace/build/tests/xpcshell/tests/netwerk/test/unit/test_psl.js -> file:///builds/worker/workspace/build/tests/xpcshell/tests/netwerk/test/unit/data/test_psl.txt:null:42
[task 2017-11-14T16:16:51.198Z] 16:16:51     INFO -  /builds/worker/workspace/build/tests/xpcshell/tests/netwerk/test/unit/test_psl.js:run_test:18
[task 2017-11-14T16:16:51.198Z] 16:16:51     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_execute_test:540
[task 2017-11-14T16:16:51.199Z] 16:16:51     INFO -  -e:null:1
[task 2017-11-14T16:16:51.200Z] 16:16:51     INFO -  exiting test
[task 2017-11-14T16:16:51.201Z] 16:16:51     INFO -  "CONSOLE_MESSAGE: (info) No chrome package registered for chrome://branding/locale/brand.properties"
[task 2017-11-14T16:16:51.201Z] 16:16:51     INFO -  <<<<<<<
Flags: needinfo?(dharvey)
Assignee

Comment 12

2 years ago
Ah ok, the tests depended on some rules that have since changes (*.il) is no longer a wildcard, updated to an equivalent test and giving it a try run @ https://treeherder.mozilla.org/#/jobs?repo=try&revision=9e3a5a683a3846718229c46837ae5bdde12927bb
Flags: needinfo?(dharvey)
Comment hidden (mozreview-request)
Assignee

Comment 14

2 years ago
That test seems fine now but seeing failures with 

> FAIL | netwerk/test/unit/test_bug414122.js | checkPublicSuffix
> [checkPublicSuffix : 57] "ar" == "musica.ar"

musica.ar was a change from the previous list, but having a hard time figuring out exactly what test_bug414122.js is trying to test and why this (and a few other changes) in particular fail
Assignee

Comment 15

2 years ago
Failures may be due to artifact builds, running another full build test @ https://treeherder.mozilla.org/#/jobs?repo=try&revision=8502dab4ed39ff25af7d49458686388366c92d77
Assignee

Comment 16

2 years ago
Yup tests are looking good with a full rebuild, relanding

Comment 17

2 years ago
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4468b446c3c5
Update psl list and related tests. r=gerv
https://hg.mozilla.org/mozilla-central/rev/4468b446c3c5
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Please request Beta approval on this when you get a chance.
Flags: needinfo?(dharvey)
Assignee

Comment 20

2 years ago
Comment on attachment 8926868 [details]
Bug 1415870 - Update psl list and related tests.

Approval Request Comment
[Feature/Bug causing the regression]: Outdated external list
[User impact if declined]: Domains isolation not working as expected
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: nope
[Why is the change risky/not risky?]: routine import of data from github
[String changes made/needed]:
Flags: needinfo?(dharvey)
Attachment #8926868 - Flags: approval-mozilla-beta?
Comment on attachment 8926868 [details]
Bug 1415870 - Update psl list and related tests.

Update the public suffix list. Beta58+.
Attachment #8926868 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.