[PP] App crashes in profile manager at startup

VERIFIED FIXED

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: jay, Assigned: dveditz)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you already have a Mozilla Registry file, apprunner should detect it and
start apprunner with your usual profile.  With build 1999091708, apprunner
doesn't seem to recognize the file and therefore brings up the Profile Manager
everytime.  If you click next a couple of times and click finish, apprunner
crashes.  If you look in HD:System Folder:Preferences for the Mozilla Registry
file, the original is there (if you didn't delete it) and a new registry file
appears but with a bunch of garbage attached to the end of the filename...here
is an example:

Mozilla Registry^&*$@^


0
(Reporter)

Updated

19 years ago
Summary: App crashes in profile manager at startup → [PP] App crashes in profile manager at startup
(Reporter)

Comment 1

19 years ago
Note that this is a Mac only problem.

Comment 2

19 years ago
*** Bug 14185 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: selmer → dveditz

Comment 3

19 years ago
This is related to Dan's checkin last night.  Somewhere a string length isn't
matched up properly.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
I think my fix works, but can't test. Seth is looking at it and I'll reopen if
it fails.
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 5

19 years ago
I fixed some bad assumptions regarding Handles being null terminated (whcih they
are not).

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
this problem has not been seen in awhile
certainly not on 1999100713

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 7

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.