PulseAudio is not found whilst using container tab

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: cubeb
P2
normal
RESOLVED WORKSFORME
15 days ago
7 days ago

People

(Reporter: David Ross, Unassigned, NeedInfo)

Tracking

({regression})

58 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 days ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

Been experiencing this for several days but this is my first opportunity to submit the bug.

Start Nightly as usual. PulseAudio is installed. Open container tab. Navigate to media requiring audio. In this case Youtube video. Play.


Actual results:

Warning "To play audio, you may need to install the required PulseAudio software".

If I open without being in a container the file plays.

There is weird behaviour, in that I just opened a different container and it worked. Open the same container, it doesn't work.


Expected results:

Media streams effortlessly and popcorn is consumed.
(Reporter)

Comment 1

15 days ago
Oh yeah sorry I have privacy.resistFingerprinting enabled
OS: Linux 4.13.11-1-ARCH
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171109100107

Updated

15 days ago
Component: Untriaged → Audio/Video: Playback
Keywords: regression
Product: Firefox → Core
Component: Audio/Video: Playback → Audio/Video: cubeb
Priority: -- → P2
Hi David,

I'm trying to reproduce this behaviour and haven't been successful.  (I'm trying on Fedora 26, not Arch Linux).

Is the issue 100% reproducible with the second tab of a container?
Does it happen with all containers?
Can you attach the output from about:support?

thanks,
Dan
Flags: needinfo?(sw1ayfe)
(Reporter)

Comment 3

7 days ago
This was a relatively consistent bug that I have not been experiencing now for several days. I feel it's been resolved somehow, so will now close.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.