Difference in displaying Images through XML vs. HTML

RESOLVED DUPLICATE of bug 22274

Status

()

Core
XML
--
major
RESOLVED DUPLICATE of bug 22274
16 years ago
16 years ago

People

(Reporter: Nandu, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
BuildID:    2002041711

Please see attached Zip file that contains a HTML doc that prints 2 images 
within a table and an XML/XSL set that does the same thing and the Sample Image 
that I used.

What actually happens is that the HTML page displays the images correctly - one 
above the other, with no gap inbetween.

In the XML/XSL table, the images are displayed one above the other. but there 
always remains a 3px or so gap between the two images, whatever I try.

As a result, all my page formatting gets screwed up, with the images going all 
over the place.

Reproducible: Always
Steps to Reproduce:
1.See Test Cases attached
(Reporter)

Comment 1

16 years ago
Created attachment 81929 [details]
Test Case for Image Formatting testing
Nandu, it would be faster us for test if you could attach your tests so that I
could just point and click to try them. In case the testcase consists of
multiple files that reference each other you need to attach first the ones that
don't depend on anything, get their URLs from Bugzilla, modify the local files
that depend on those, and finally attach the rest.

Without having looked at your samples, I have a couple of further tests you
could do:

1) Try the HTML testcase in strict layout mode. You can achieve that by adding
following to the beginning of the document:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
            "http://www.w3.org/TR/html4/strict.dtd">

  If you now see the ~3px gap, it means it is not a bug. In XML we always
operate in strict layout mode.

2) Eliminate XSLT from your testcase. In other words, we want to see if it is an
XHTML bug or XSLT bug. Your XSLT stylesheet produces XHTML in Mozilla. So, just
create the XHTML document by hand and see if the bug occurs there. If it does,
then it is an XHTML. If it does not apear there, but appears in the XSLT
transformed case it is XSLT bug.

Updated

16 years ago
QA Contact: petersen → rakeshmishra
This is a strict layout mode issue (and invalid; the layout is correct).  Please
see bug 22274 for more information.

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.