Closed Bug 1416162 Opened 2 years ago Closed 2 years ago

Invalid state element error has incorrect error code

Categories

(Testing :: web-platform-tests, defect)

defect
Not set

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: majorpetya, Assigned: majorpetya)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce:

I've changed the testing/web-platform/tests/webdriver/tests/cookies/add_cookie.py test to intentionally fail with an invalid cookie domain error (added a leading dot character to the domain - which currently fails due to a bug), however the error code reported by the test framework was InvalidElementStateException. 


Actual results:

The test report reported that an InvalidElementStateException occurred.


Expected results:

The test report should have reported that an InvalidCookieDomainException occurred.
Looks like that this reporting issue is caused by a copy-paste error in testing/web-platform/tests/tools/webdriver/webdriver/error.py . The InvalidElementStateException type has the same error code as the InvalidCookieDomainException type.
Comment on attachment 8927248 [details]
Bug 1416162 - Fix error code for InvalidElementStateException

https://reviewboard.mozilla.org/r/198550/#review203730
Attachment #8927248 - Flags: review?(james) → review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/2a26d588efdc
Fix error code for InvalidElementStateException r=jgraham
https://hg.mozilla.org/mozilla-central/rev/2a26d588efdc
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Assignee: nobody → majorpetya
You need to log in before you can comment on or make changes to this bug.