Crash in OOM | large | js::AutoEnterOOMUnsafeRegion::crash | js::AutoEnterOOMUnsafeRegion::crash | js::TenuringTracer::moveToTenuredSlow

RESOLVED DUPLICATE of bug 1257387

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 1257387
14 days ago
14 days ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, regression})

Trunk
Unspecified
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox58 affected)

Details

(crash signature)

(Reporter)

Description

14 days ago
This bug was filed from the Socorro interface and is
report bp-5cca9907-cc3b-4a6c-a060-a129e0171110.
=============================================================

Seen while looking at crash stats - this seems to have spiked a bit in the November 8th build, and although there are only a few installs there overall there are 596 crashes/34 installs in 58 nightly and 61/20 in 58 beta: http://bit.ly/2iLgU55

Crash stats shows this signature was first seen on 2017-10-20.

Top 10 frames of crashing thread:

0 xul.dll js::AutoEnterOOMUnsafeRegion::crash js/src/jscntxt.cpp:1666
1 xul.dll js::AutoEnterOOMUnsafeRegion::crash js/src/jscntxt.cpp:1680
2 xul.dll js::TenuringTracer::moveToTenuredSlow js/src/gc/Marking.cpp:2948
3 xul.dll js::TenuringTracer::traverse<JSObject> js/src/gc/Marking.cpp:2692
4 xul.dll js::gc::StoreBuffer::MonoTypeBuffer<js::gc::StoreBuffer::CellPtrEdge>::trace js/src/gc/Marking.cpp:2721
5 xul.dll js::Nursery::doCollection js/src/gc/Nursery.cpp:783
6 xul.dll js::Nursery::collect js/src/gc/Nursery.cpp:668
7 xul.dll js::gc::GCRuntime::minorGC js/src/jsgc.cpp:7704
8 xul.dll `mozilla::CycleCollectedJSContext::IsIdleGCTaskNeeded'::`2'::IdleTimeGCTaskRunnable::Run xpcom/base/CycleCollectedJSContext.cpp:397
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1037

=============================================================
(In reply to Marcia Knous [:marcia - use ni] from comment #0)
This is OOM, and the same as bug 1257387.
Status: NEW → RESOLVED
Last Resolved: 14 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1257387
You need to log in before you can comment on or make changes to this bug.