Closed Bug 1416374 Opened 3 years ago Closed 3 years ago

Desktop bookmarks engine telemetry can report httperrors of code "error.engine.abort.applyincoming"

Categories

(Firefox :: Sync, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: tcsc, Assigned: tcsc)

Details

Attachments

(1 file)

While some ATMO stuff is thinking, I looked around our telemetry and came up with [0].

You'll note that the top most error, reported by desktop bookmarks, is decidedly not an HTTP error. It's not even a real error code intended to be used outside the engine, it's this value[1]. This is caused by the mapDupe here, which can be called from inside uploadOutgoing (by way of [2]).

Given that this probably is only thrown in db corruption cases(?), it seems like just handling it inside the telemetry code instead of trying to make _createRecord do the right thing is the best solution.

Mostly trivial patch incoming.

[0] https://sql.telemetry.mozilla.org/queries/48939#131851
[1] https://searchfox.org/mozilla-central/source/services/sync/modules/engines.js#681
[2] https://searchfox.org/mozilla-central/source/services/sync/modules/engines/bookmarks.js#545
Comment on attachment 8927491 [details]
Bug 1416374 - Handle getting an abortincoming error in sync telemetry

https://reviewboard.mozilla.org/r/198812/#review203994

LGTM, thanks! (assuming that test fails without your patch :)
Attachment #8927491 - Flags: review?(markh) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a279f3cd1b8b
Handle getting an abortincoming error in sync telemetry r=markh
https://hg.mozilla.org/mozilla-central/rev/a279f3cd1b8b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.