Mach installs an incorrect version of java for android builds

RESOLVED DUPLICATE of bug 1477487

Status

enhancement
RESOLVED DUPLICATE of bug 1477487
2 years ago
3 months ago

People

(Reporter: mossop, Assigned: nalexander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm told that java8 is required but currently mach installs java9 on OSX.

We are now installing all required packages via Homebrew. You will see a lot of
output as packages are built.

==> Caveats
This Cask makes minor modifications to the JRE to prevent issues with
packaged applications, as discussed here:

  https://bugs.eclipse.org/bugs/show_bug.cgi?id=411361

If your Java application still asks for JRE installation, you might need
to reboot or logout/login.

Installing this Cask means you have AGREED to the Oracle Binary Code
License Agreement for Java SE at

  https://www.oracle.com/technetwork/java/javase/terms/license/index.html

==> Satisfying dependencies
==> Downloading http://download.oracle.com/otn-pub/java/jdk/9.0.1+11/jdk-9.0.1_osx-x64_bin.dmg
######################################################################## 100.0%
==> Verifying checksum for Cask java
==> Installing Cask java
==> Running installer for java; your password may be necessary.
==> Package installers may write to any location; options such as --appdir are ignored.
==> installer: Package name is JDK 9.0.1
==> installer: Installing at base path /
==> installer: The install was successful.
We installed a recent Java toolchain for you. We agreed to the Oracle Java
license for you by downloading the JDK. If this is unacceptable you should
uninstall.

--2017-11-10 15:11:32--  https://dl.google.com/android/repository/sdk-tools-darwin-3859397.zip
Resolving dl.google.com... 172.217.3.206, 2607:f8b0:400a:809::200e
Connecting to dl.google.com|172.217.3.206|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 86182133 (82M) [application/zip]
Saving to: 'sdk-tools-darwin-3859397.zip'

sdk-tools-darwin-3859397.zip                                        100%[=================================================================================================================================================================>]  82.19M  28.4MB/s    in 2.9s    

2017-11-10 15:11:35 (28.4 MB/s) - 'sdk-tools-darwin-3859397.zip' saved [86182133/86182133]

Unpacking /Users/dave/.mozbuild/android-sdk-macosx/mozboot/sdk-tools-darwin-3859397.zip...
Unpacking /Users/dave/.mozbuild/android-sdk-macosx/mozboot/sdk-tools-darwin-3859397.zip... DONE

We are now installing the following Android packages:
platform-tools
build-tools;25.0.3
platforms;android-23
extras;android;m2repository
extras;google;m2repository
emulator

You may be prompted to agree to the Android license. You may see some of
output as packages are downloaded and installed.

Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
	at com.android.repository.api.SchemaModule$SchemaModuleVersion.<init>(SchemaModule.java:156)
	at com.android.repository.api.SchemaModule.<init>(SchemaModule.java:75)
	at com.android.sdklib.repository.AndroidSdkHandler.<clinit>(AndroidSdkHandler.java:81)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:117)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:93)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:185)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
	... 5 more
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['/Users/dave/.mozbuild/android-sdk-macosx/tools/bin/sdkmanager', '--package_file=/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/android-packages.txt']' returned non-zero exit status 1

  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/mach_commands.py", line 32, in bootstrap
    bootstrapper.bootstrap()
  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/bootstrap.py", line 296, in bootstrap
    getattr(self.instance, 'install_%s_packages' % application)()
  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/osx.py", line 206, in install_mobile_android_artifact_mode_packages
    self.package_manager)(artifact_mode=True)
  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/osx.py", line 366, in ensure_homebrew_mobile_android_packages
    no_interactive=self.no_interactive)
  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/android.py", line 180, in ensure_android
    ensure_android_packages(sdkmanager_tool=sdkmanager_tool, no_interactive=no_interactive)
  File "/Users/dave/mozilla/source/trunk/python/mozboot/mozboot/android.py", line 233, in ensure_android_packages
    subprocess.check_call(args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
Assignee: nobody → nalexander
Status: NEW → ASSIGNED

Updated

Last year
Product: Core → Firefox Build System

This should have been addressed (in mach bootstrap) by https://bugzilla.mozilla.org/show_bug.cgi?id=1477487.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477487
Component: General → Bootstrap Configuration
You need to log in before you can comment on or make changes to this bug.