hardware video acceleration doesn't work on linux for HTML5 videos

RESOLVED DUPLICATE of bug 1210726

Status

()

defect
RESOLVED DUPLICATE of bug 1210726
2 years ago
2 years ago

People

(Reporter: lvm, Unassigned)

Tracking

56 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
Hardware video acceleration doesn't seem to work for HTML5 video playback on linux both in Firefox 56 and Seamonkey 2.49.1 and 2.55 nightly: compared to Chromium CPU usage is two times higher while GPU remains idle. In practical terms it means that on my system in gecko 1080p youtube HTML5 videos sometime stutter and 1080p60 are totally unplayable while Chromium plays both without issues. I seem to remember that when youtube supported flash video player its CPU requirements in Seamonkey also were significantly lower than that of HTML5 player and it did use hardware acceleration. No such issue on windows 7 with directX 11 - CPU and GPU usages both for gecko and chrome-based browsers are similar but in the thread here http://forums.mozillazine.org/viewtopic.php?f=3&t=3034885 one person complains about a similar issue on windows XP with directX 9.

Using a clean profile or setting media.hardware-video-decoding.force-enabled, layers.acceleration.force-enabled, webgl.force-enabled, stagefright.force-enabled changed nothing.

My system is ubuntu 14.04, vdpau and vaapi (libva1) are installed and working for other programs, nvidia GT240 (supports vdpau feature set C)
Component: General → Audio/Video: Playback
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210726
Windows xp is no longer supported and doesn't provide hardware decoding system API, this was only introduced in vista (also no longer supported)
You need to log in before you can comment on or make changes to this bug.