sidebar ignores first click when window not in focus

RESOLVED DUPLICATE of bug 1416492

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1416492
6 days ago
6 days ago

People

(Reporter: u597845, Unassigned)

Tracking

56 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 days ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171024165158

Steps to reproduce:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0

When clicking on an element in the sidebar of a FF window which is not in focus, two clicks are needed instead of one.

Example:
I have two FF windows open. One of them is not in focus. Its sidebar presents the bookmarks. I click on "Other Bookmarks".


Actual results:

The FF window I clicked on is now in focus, but the "Other Bookmarks" folder does not expand. I have to click it again.


Expected results:

The "Other Bookmarks" folder should have expanded after one click instead of two. This is the behavior I expect from basic browser ui elements (e.g.: buttons in the toolbar).
(Reporter)

Comment 1

6 days ago
Closing the sidebar via the X-button only needs one click.
(Reporter)

Updated

6 days ago
OS: Unspecified → Mac OS X

Comment 2

6 days ago
Please close this bug and consider Bug 1416492 instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1416492
You need to log in before you can comment on or make changes to this bug.